Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-23-2016, 08:27 AM   #1
Senior Member
sugus's Avatar

Join Date: Jun 2016
Location: Zürich
Posts: 188
Shutter does NOT

Hi folks

My "spare" 645 has a slightly problem. Look here




Any idea's?

Daniel

06-23-2016, 09:42 AM   #2
Moderator
Loyal Site Supporter
BigMackCam's Avatar

Join Date: Mar 2010
Location: North East of England
Posts: 6,670
Are you running with fresh batteries? I've heard of the mirror staying up when batteries are running low...
06-23-2016, 02:06 PM   #3
Senior Member
sugus's Avatar

Join Date: Jun 2016
Location: Zürich
Posts: 188
Original Poster
Yes of corse, batterys are new. I've done the test with another grip/motor/winder and the same issue! Yes testfilm loaded
06-26-2016, 06:47 AM   #4
Senior Member
sugus's Avatar

Join Date: Jun 2016
Location: Zürich
Posts: 188
Original Poster
A small update:

When I hold the camera horizonzaly the problem occours. When I hold the camera down, vertically, the problem does NOT exist!

Any ideas??

06-26-2016, 08:25 AM   #5
Site Supporter
gofour3's Avatar

Join Date: Oct 2008
Location: Vancouver, Canada
Posts: 5,342
QuoteOriginally posted by sugus Quote
Any ideas??
Welcome to the forum!

I would email Eric, he should be able to help:

Pentax Camera Repair

Phil.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
645d, 645z, camera, medium format
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutter not opening, shutter button stuck and unresponsive ( Pentax ME) pentytaxy Troubleshooting and Beginner Help 4 04-16-2016 12:54 AM
AstroTracer Quirks: Does anybody know when it works/does not work? maxxxx Pentax Camera and Field Accessories 16 11-27-2014 01:13 PM
K-5 shutter does not release lubibubi Pentax K-5 7 04-12-2014 09:47 PM
Shutter count tool does not work with K-30 Edgar_in_Indy Pentax K-30 & K-50 7 07-28-2012 02:54 AM
Shutter does not work when autoflash is on. Daniellah Troubleshooting and Beginner Help 8 04-25-2011 06:49 AM



All times are GMT -7. The time now is 02:23 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top