Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-06-2019, 06:13 PM   #1
Forum Member




Join Date: Feb 2018
Posts: 98
HD Pentax DFA645 Macro 1:2.8 90mm ED AW SR - problem shake reduction broken

My 645Z with a HD Pentax DFA645 Macro 1:2.8 90mm ED AW SR doesn't have SR working.
I think the lens may be "broken".
When I power up the camera, the lens "buzzes", there is a pause, and then it "buzzes" two more times.
The SR hand on the display shows OFF in white.
I have double checked all my settings, and can't seem to get it to turn on.
Movie mode shows the hand ON in white.

Any ideas?
Is my (few months old) lens broken?

Unfortunately I don't have another SR lens or another body nearby to test with. Everything else seems to be working with body, so am thinking the lens has falied somehow.

I baby it so cannot explain, never dropped etc.

Any suggestions?

03-06-2019, 06:58 PM   #2
Pentaxian




Join Date: Mar 2007
Location: Christchurch, New Zealand
Photos: Gallery
Posts: 732
Have you tried cleaning the lens contacts? On the lens and on the body?

Regards

Chris
03-06-2019, 10:14 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 48,552
Sounds like a mechanical failure to me. Good news is, if the lens is only a few months old, warranty will cover the repair.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

03-07-2019, 05:54 AM   #4
Forum Member




Join Date: Feb 2018
Posts: 98
Original Poster
What's the "normal" startup sound for the lens? One "buzz" ?

03-07-2019, 02:26 PM   #5
Junior Member




Join Date: Jan 2016
Posts: 34
QuoteOriginally posted by ProfessorBuzz Quote
What's the "normal" startup sound for the lens? One "buzz" ?
Mine gives me one quick buzz at startup. I have mine set at option #2 in #28 of the "C" menu so shake reduction comes on when I 1/2 press the shutter button. Option #1 has it come on at the moment of capture which may be why you don't see it as being on when looking at the screen.
Greg
03-11-2019, 10:39 AM   #6
Forum Member




Join Date: Feb 2018
Posts: 98
Original Poster
Thanks for the suggestions. Ricoh referred me to Sun Camera Service in Toronto, and I dropped it off there. They don't have a 645z body or lens to compare against at Sun. After a quick check, the lens is on its way to Japan to be repaired. In theory, I'll have it back in 4 weeks.
04-15-2019, 09:28 AM   #7
Pentaxian




Join Date: Feb 2008
Photos: Gallery | Albums
Posts: 431
Similar problem here: Help
04-20-2019, 02:13 PM   #8
Pentaxian




Join Date: Apr 2013
Location: Brisbane, Australia
Photos: Albums
Posts: 714
If you have the camera set to mirror-lockup on the side dial, no matter what you do the IS will not come on. Try that.

05-05-2019, 06:08 AM   #9
Forum Member




Join Date: Feb 2018
Posts: 98
Original Poster
QuoteOriginally posted by ProfessorBuzz Quote
Thanks for the suggestions. Ricoh referred me to Sun Camera Service in Toronto, and I dropped it off there. They don't have a 645z body or lens to compare against at Sun. After a quick check, the lens is on its way to Japan to be repaired. In theory, I'll have it back in 4 weeks.
The lens came back at the end of April, so it was about 7 weeks for the round trip, and the lens seems to be behaving normally - one quick buzz on startup. So am happy its done under warranty.
I got the 5-cent tour - Sun Camera Service has 2 Pentax techs there, and a bunch of folks that do Canon, Nikon, camcorders, and some film cameras. An impressive group of very talented people and some interesting equipment.
Nice people.
05-05-2019, 07:22 AM - 1 Like   #10
Forum Member




Join Date: Feb 2018
Posts: 98
Original Poster
QuoteOriginally posted by Thomas Quote
Similar problem here: Help
I added some (extensive) comments on troubleshooting what is going on with SR lenses over in that thread. Hopefully it helps.
Bottom line:

SR Shaky Hand ON = the SR is actively stabilizing the lens right now.
SR Shaky Hand OFF = the SR is not being activated or is turned off by the lens switch or a failure.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
645d, 645z, 90mm, body, camera, hand, hd pentax dfa645, lens, macro, macro 1:2.8 90mm, medium format, pentax dfa645 macro, sr, white
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Pentax 90mm f/2.8 D FA 645 Macro ED AW SR Lens kparseg Sold Items 11 04-27-2016 10:44 PM
For Sale - Sold: HD PENTAX-D FA 645 MACRO 90mm f/2.8 ED AW SR !!!!PRICE REDUCED!!!! crazyfrog89 Sold Items 9 11-16-2015 10:50 AM
[First Look] Pentax 645Z with HD FA645 90mm F2.8 Marco AW SR AspireNews Pentax Medium Format 6 07-16-2014 12:09 AM
PENTAX Announces New 90mm Macro Lens New HD PENTAX D FA 645 MACRO 90mm F2.8 ED AW SR Adam Homepage & Official Pentax News 0 09-10-2012 03:00 PM



All times are GMT -7. The time now is 02:29 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top