Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-07-2019, 09:01 PM   #1
New Member




Join Date: Feb 2018
Posts: 4
645Z Mode Dial fine (thought it had malfunctioned)

My 16 month old 645Z has a malfunction of the mode dial. When I place the dial in TV,SV or P,it stays on Aperture priority. I can use the dial and the camera switches to all the other modes appropriately. However, these 3 settings remain in A (aperture priority mode).I've updated software to 1.30. Reset to factory settings and reset all custom functions to no avail. The camera has been relatively lightly used for a camera of this quality. No proffesional use. Strictly amateur. Any ideas?

Of course, 5 months out of warranty period. Precision Camera, the Ricoh certified repair shop, charges 850 bucks just to look at it. I can use it perfectly well without those three exposure modes but Im afraid the dial will conk out completely at some point on a trip. Any ideas??


Last edited by MarkJerling; 09-09-2019 at 05:09 PM.
09-07-2019, 09:08 PM - 2 Likes   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 48,870
The fact that only these 3 modes are giving you trouble suggests that perhaps the aperture ring on the lens isn't set to "A" (you'd see the aperture value underlined in the viewfinder), or that communication with the lens isn't working (you'd see F-- in the viewfinder).

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

09-08-2019, 07:25 PM   #3
New Member




Join Date: Feb 2018
Posts: 4
Original Poster
THANK YOU! I had never used these modes and that was exactly the problem!!!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
645d, 645z, 645z mode, aperture, camera, malfunction, medium format, mode, modes, priority, reset, settings
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-3 Mode dial not working leonardotmnt Repairs and Warranty Service 5 09-01-2018 11:20 AM
K-1 warranty repair of mode dial ....thanks Pentax Syntax Pentax K-1 2 09-28-2017 11:55 AM
645Z Malfunction Thomasbrowphoto Pentax Medium Format 30 06-17-2015 04:32 AM
Rear E-Dial Wouldn’t Dial. This Ever Happen to You? veezchick Troubleshooting and Beginner Help 15 11-04-2014 08:50 PM
Film type dial / exposure counter control dial. keeping on 220 elephantvanishes Pentax Medium Format 6 10-15-2012 10:41 AM



All times are GMT -7. The time now is 06:43 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top