Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-02-2021, 01:32 PM   #1
New Member




Join Date: Feb 2021
Posts: 2
Autofocus not working on Pentax 645n

Hi everyone,

I've acquired a Pentax 645n with a 55mm manual lens last December, I've been shooting with it and everything works well so far
Now, I just bought a used FA 120mm Macro F4 lens today (autofocus lens) form Kamerastore.com and when I tried it on, I could only use manual focus and autofocus didn't seem to work.

The lens itself is used but in good mechanical and optical condition as certified by Kamerastore, no apparent sign of shock or anything. And all functions of the camera body have been working perfectly so far.
So I'm wondering where that autofocus problem could come from ?

Do you think I should try an open up the camera ?
Any insight is welcome!

Vic from France

02-02-2021, 01:37 PM   #2
Moderator
Site Supporter
Loyal Site Supporter
Sandy Hancock's Avatar

Join Date: Feb 2012
Location: Adelaide Hills, South Australia
Photos: Gallery | Albums
Posts: 9,628
Hi Vic. Welcome to the Forums!

To engage autofocus on the FA645 lenses, you need to push the focus ring away from you so it clicks into place and the words "AUTO FOCUS" are exposed on the top of the lens barrel. Then you're good to go
02-03-2021, 12:43 AM   #3
New Member




Join Date: Feb 2021
Posts: 2
Original Poster
Hi Sandy,

I do know how FA645 lenses work and I did push the focus ring forward and clicked it into place. Still the lens doesn't autofocus, nothing happens...
02-03-2021, 01:10 AM   #4
Moderator
Site Supporter
Loyal Site Supporter
Sandy Hancock's Avatar

Join Date: Feb 2012
Location: Adelaide Hills, South Australia
Photos: Gallery | Albums
Posts: 9,628
QuoteOriginally posted by victorguerrier Quote
I do know how FA645 lenses work and I did push the focus ring forward and clicked it into place. Still the lens doesn't autofocus, nothing happens...
You might be surprised how often users aren't aware of that feature

In your case though, I'm out of suggestions. Good luck.

02-03-2021, 01:55 AM   #5
Pentaxian
fs999's Avatar

Join Date: Jul 2008
Location: Luxembourg
Photos: Gallery
Posts: 6,040
You should clean the contacts on the camera and on the lens. That can help.
02-03-2021, 11:16 AM   #6
Site Supporter
Site Supporter




Join Date: Nov 2008
Location: Washington DC, USA
Photos: Albums
Posts: 603
I can't remember everything about that lens (sold it and kept my A version), but I thought that on the rear mount there is an autofocus shaft that turns the AF mechanism - the camera has the screw drive portion that fits into the female part on the lens. I would start there and see if the autofocus drive on the camera seems to work and if the one on the lens spins when you turn the focus collar/ring.

Jaron Ball (NimsloGuy) takes apart an FA 75mm with defective focusing. Might be worth a look through the video to see the focus shaft footage.
He is great and has fixed three 645N bodies for me already. One was completely dead and he used parts from other 645N bodies to give me a camera that works perfectly.
02-09-2021, 12:11 AM   #7
New Member




Join Date: Feb 2021
Posts: 1
QuoteOriginally posted by Sandy Hancock Quote
Hi Vic. Welcome to the Forums!

To engage autofocus on the FA645 lenses, you need to push the focus ring away from you so it clicks into place and the words "AUTO FOCUS" are exposed on the top of the lens barrel. Then you're good to go
QuoteOriginally posted by Sandy Hancock Quote
To engage autofocus on the FA645 lenses, you need to push the focus ring away from you so it clicks into place and the words "AUTO FOCUS" are exposed on the top of the lens barrel.
Hi there, I also am having trouble with recently purchased 75mm FA lens on a Pentax 645N body. The autofocus is not working at all ( it is on AF etc ) . I do not see what you mean by the above advice - I cannot push the focus ring away - are you able to explain this in more detail ( maybe a photo ) , thanks?
02-22-2021, 07:28 PM   #8
Site Supporter
Site Supporter




Join Date: Nov 2008
Location: Washington DC, USA
Photos: Albums
Posts: 603
QuoteOriginally posted by nwinsley Quote
Hi there, I also am having trouble with recently purchased 75mm FA lens on a Pentax 645N body. The autofocus is not working at all ( it is on AF etc ) . I do not see what you mean by the above advice - I cannot push the focus ring away - are you able to explain this in more detail ( maybe a photo ) , thanks?
The FA 75mm does not have the same mechanism as some other FA lenses. Your FA 75mm has a simple switch to move between autofocus and manual focus. Some lenses have a clutch type system, where you move the entire focus grip forward and back to engage in autofocus or to switch to manual focus.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
645d, 645n, 645z, autofocus, camera, fa 120mm f/4, lens, medium format, pentax, pentax 645n
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
DA 300 F4 autofocus not working vievetrick Repairs and Warranty Service 20 10-14-2020 10:36 AM
Flash on 645n not consistently working BDK Flashes, Lighting, and Studio 7 02-01-2017 12:21 PM
Pentax-F 50mm autofocus not working rafoarc Troubleshooting and Beginner Help 5 05-11-2015 04:03 PM
Pentax 200mm f/2.8 autofocus not working? milka Pentax SLR Lens Discussion 15 02-26-2013 12:46 PM
Pentax-DA 35mm F2.4 AL autofocus not working mr_white Troubleshooting and Beginner Help 6 01-20-2012 04:01 PM



All times are GMT -7. The time now is 01:26 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top