Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-25-2021, 01:54 AM   #1
New Member




Join Date: Dec 2021
Posts: 5
Pentax 6x7 non-MLU transport/last frame issue

Hello everyone, I recently bought a non MLU 6x7. After shooting a roll, I ran into an issue where the last frame would be cropped hence only getting 9 exposures per roll.


Iíve read on this thread that this issue might be resolved by aligning the start arrow with the tiny screw just below the battery check button (instead of the orange dot)
https://www.talkphotography.co.uk/threads/pentax-6x7-uneven-frame-spacing.673479/

And Iíve tried this to no avail (still getting the 10th frame cropped). I suspect that I did not manage to align the start arrow well below the screw. Does anyone here know how to correctly align the start arrow further to the left of the orange dot? Has anyone encountered this lost frame issue?

Many thanks!

Hereís the cropped last frame:

Attached Images
 
12-26-2021, 06:41 AM   #2
Loyal Site Supporter
Loyal Site Supporter




Join Date: Feb 2018
Posts: 1,678
What film are you using? Have you got the correct alignment marks on the film paper backing?
Are the frames aligned with the numbering on the film edge?
Have you tried taking a roll elsewhere for processing?
12-27-2021, 11:05 AM   #3
Pentaxian




Join Date: Feb 2009
Location: Arizona
Posts: 1,247
Losing the last frame is usually caused by excess spacing between frames. This is fairly common on the non lock up bodies. There is a fix for this, I'm told.

Last edited by desertscape; 12-28-2021 at 10:32 AM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
645d, 645z, 6x7, arrow, camera, dot, frame, issue, medium format, pentax 6x7 non-mlu, screw, start
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax 6x7 MLU parts needed Bruxxcam Pentax Medium Format 6 12-13-2020 01:33 PM
Strange button on my new 6x7 non-MLU greenmage Pentax Medium Format 7 11-08-2020 03:12 AM
Pentax 6x7 mlu frame counter thinks its in 220 mode rustyneedles Pentax Medium Format 3 05-12-2019 08:26 PM



All times are GMT -7. The time now is 10:41 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top