Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-08-2009, 12:59 PM   #1
Pentaxian
Swift1's Avatar

Join Date: Sep 2009
Location: Oregon
Photos: Gallery | Albums
Posts: 3,952
67 MLU Question.

First of all, I should introduce myself. I am new here but I have been reading this forum for months and have found the forum and the lens reviews to be an indispencable resource.

I purchased a K10D a year and a half ago and since then have developed a serious case of CBA and LBA. I now own 15 lenses, 6 bodies and all kinds of accessories.

My most recent acquisition is a 67 kit. After purchasing the kit I sent it to a reputable repair shop for a full CLA and to have the pressure plate and winding mechanism repaired.
Since getting it back, I have run 2 rolls of film through it using MLU on 90% of the shots and I have randomly had the problem of the mirror getting stuck on its way up.
I then have to press the little black button below the shutter release and it will finish going up.
The battery is brand new.

Is this a common problem?

Any help will be much appreciated,

Swift1

09-08-2009, 07:51 PM   #2
New Member




Join Date: Jun 2008
Location: Knoxville
Posts: 6
Hi Swift1,
Sometimes when a tech must repair many area's of a unit each function is checked maybe once or twice. If the tech is aware of the type of problem incountered by the user this section can be tested several times and adjusted to work each time used. If might be a case where you need to return it for further testing. The shutter release soleniod is not working correctly.
Eric
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, forum, kit, medium format, mlu
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mirror up (MLU) on the K7 - Who's using that ... jpzk Pentax DSLR Discussion 16 09-18-2010 07:09 PM
Kx - MLU w/ bracketing? bnorikane Pentax DSLR Discussion 8 12-24-2009 12:29 PM
what to do if 1.01 doesn't fix MLU hotpixels on K20D? kenyee Pentax DSLR Discussion 6 01-08-2009 09:28 AM
Pentax 6x7 non MLU Mark S. Pentax SLR Lens Discussion 0 11-16-2008 10:42 AM
SR and MLU awetmore Pentax DSLR Discussion 9 06-05-2007 11:14 AM



All times are GMT -7. The time now is 02:39 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top