Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-26-2009, 10:15 AM   #1
Senior Member




Join Date: Mar 2007
Location: Lower Left Coast, USA
Photos: Gallery
Posts: 255
Pentax 645N Brain Dead?

I’m posting this in a number of Pentax/MF fora in the hope of finding a simple solution to my problem. I apologize if you encounter this elsewhere.

I received a used Pentax 654N with a 75mm FA645 f2.8 lens yesterday that isn’t working. I’ve photographed with 35mms for over 30 years, and with Pentaxs (Pentaxes, Pentaxia, ?) since the mid 80s, so I know my way around cameras. I’m pretty sure this one is busted, but it’s my first 645, or MF for that matter, so I’m hoping someone here with experience with the camera can point out something simple I’m missing.

The symptoms are:
1) With new batteries, it will not auto focus or advance a roll of film.
2) The top LCD is functional (ISO can be changed), but the Viewfinder Display only displays ‘1000 F—‘ regardless of aperture or shutter speed settings on the camera.
3) With the lens set to AF or MF, and the battery holder (with batteries) freshly inserted, when the shutter release is fully pressed, there is a ‘click’ from the front of the camera (I suspect it is the shutter trying to release) and the Viewfinder Display turns off and will not come back on until after the battery holder has been removed and replaced. With the lens set to AF, MF, or the lens removed, the Viewfinder Display illuminates when the shutter release is pressed half way, and goes off several seconds later.

I bought it from a well-known east coast (USA) camera retailer. I’ve emailed their support department and got the auto-reply “Our support center is currently closed in observance of the Yom Kippur Holiday, please try emailing again on September 29th”. I will try them again Tuesday, but am hoping to take some test shots this weekend.

Thanks in advance for any help you can lend.
*** Figured it out ***
So, I fiddled with it, and pressed the Mid-roll Wind-up Button a few times and heard a ‘click’. I put the batteries back in, turned it on, and it made a whirring sound as though it was trying to rewind the film (which wasn’t there). I tried putting a roll of film in, pressed the shutter release, and ERR showed up on the LCD. Dooooh! I pulled the film holder out, pressed the Mid-roll Wind-up Button again, and heard a click, put it back in, turned the power back on, pressed the shutter release and it rewound the film (I suppose I put it in backwards). I pulled the film out, put the empty back on, and it did the same as before, no AF, no shutter release. I tried to load another roll of film, and now IT WORKS! The AF works, the viewfinder display indicates the correct settings, and it takes pictures! Yes, a new old camera with quirks.


Last edited by iCrop; 09-26-2009 at 02:01 PM. Reason: Problem solved!
10-12-2009, 05:40 PM   #2
Senior Member
guidoanselmi's Avatar

Join Date: Sep 2009
Location: LA, CA
Photos: Gallery | Albums
Posts: 131
I think you put the film in backwards the first time.

Don't worry, I did too!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, display, film, holder, lens, medium format, release, roll, shutter, viewfinder
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Second Bush with a brain........ jeffkrol General Talk 2 06-16-2010 07:04 AM
So there is a bush with a brain jeffkrol General Talk 31 05-23-2010 07:43 AM
Nature I Spy Ibis - Birds on the Brain Sailor Post Your Photos! 20 01-15-2010 06:42 AM
Brain Disease? Rupert General Talk 5 08-12-2009 12:17 PM
Problems with 540FGZ (or with the brain) honopik Pentax Camera and Field Accessories 9 10-18-2007 12:28 PM



All times are GMT -7. The time now is 08:20 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top