Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-08-2009, 11:20 AM   #1
Pentaxian
Swift1's Avatar

Join Date: Sep 2009
Location: Oregon
Photos: Gallery | Albums
Posts: 3,807
New 67 Blog

Hey all, just thought I would let you know about my blog. I just started shooting with a P67 and thought it would be fun to share my experience. I am new to MF and I'm sure it will be a learning experiences. Feel free to leave comments and tips :-)


P67Shooter

Swift1

11-08-2009, 12:04 PM   #2
Pentaxian




Join Date: Jul 2009
Location: Seattle
Posts: 6,929
Why in the heck did you sell off that 165mm LS? I'd never get rid of mine. It comes in way too handy. The goal is to collect more lenses; not get rid of them Also, read the 90mm LS manual for how to take a vibration-free shot using only using the leaf shutter if you got it; otherwise, I can post the instructions. A handy feature for stills and landscape when you want a sharp shot.

Last edited by tuco; 11-08-2009 at 12:21 PM.
11-08-2009, 12:42 PM   #3
Pentaxian
Swift1's Avatar

Join Date: Sep 2009
Location: Oregon
Photos: Gallery | Albums
Posts: 3,807
Original Poster
I originally bought the entire kit with plans to sell all of it. I didn't really decide to get into MF until after I sold the 67II, 165 LS, and the Helicoid Ext. tube. I now wish I had kept all of it. But that Is part of learning eh?

Swift1
11-08-2009, 10:05 PM   #4
Veteran Member




Join Date: Feb 2008
Location: Toronto
Posts: 3,915
maybe you would like to bump this thread as you have new updates to the blog. would make it a bit easier for others who don't have you on their blogroll to follow.

good luck with medium format!

11-09-2009, 10:34 AM   #5
Pentaxian
Swift1's Avatar

Join Date: Sep 2009
Location: Oregon
Photos: Gallery | Albums
Posts: 3,807
Original Poster
Thanks for the tip K100D, will try to remember to bump as I update.

Swift1
11-10-2009, 01:00 PM   #6
Veteran Member




Join Date: Dec 2006
Location: Copenhagen
Photos: Gallery
Posts: 1,845
QuoteOriginally posted by Swift1 Quote
Hey all, just thought I would let you know about my blog. I just started shooting with a P67 and thought it would be fun to share my experience. I am new to MF and I'm sure it will be a learning experiences. Feel free to leave comments and tips :-)


P67Shooter
Thanks for the info.

Chris Wilson also has a Pentax 67 blog :
Travel 67 - Chris Willson

Chris Willson's Blog
11-27-2009, 06:58 PM   #7
Pentaxian
Swift1's Avatar

Join Date: Sep 2009
Location: Oregon
Photos: Gallery | Albums
Posts: 3,807
Original Poster
Bump for update.
12-01-2009, 05:59 PM   #8
Veteran Member




Join Date: Feb 2008
Location: Toronto
Posts: 3,915
QuoteOriginally posted by Jonson PL Quote
Thanks for the info.

Chris Wilson also has a Pentax 67 blog :
Travel 67 - Chris Willson

Chris Willson's Blog
good link

QuoteOriginally posted by Swift1 Quote
Bump for update.
in your picture, how did you such blue colors from 160S, did you amp up the saturation?

12-01-2009, 08:47 PM   #9
Pentaxian
Swift1's Avatar

Join Date: Sep 2009
Location: Oregon
Photos: Gallery | Albums
Posts: 3,807
Original Poster
QuoteOriginally posted by k100d Quote
in your picture, how did you such blue colors from 160S, did you amp up the saturation?
I used a polarizer in that shot. Also, my Takumar 90mm 2.8 seems to be a little cooler than some of my other lenses which may make the blues a little bluer.

Swift1
02-13-2010, 10:54 PM   #10
Pentaxian
Swift1's Avatar

Join Date: Sep 2009
Location: Oregon
Photos: Gallery | Albums
Posts: 3,807
Original Poster
Bump for updates.
P67Shooter

Swift1
02-13-2010, 10:58 PM   #11
Loyal Site Supporter
SteveM's Avatar

Join Date: Jan 2009
Location: Vancouver Island, BC, Canada
Photos: Gallery
Posts: 3,295
Great pic..what are you using for a scanner?
02-13-2010, 11:19 PM   #12
Pentaxian
Swift1's Avatar

Join Date: Sep 2009
Location: Oregon
Photos: Gallery | Albums
Posts: 3,807
Original Poster
QuoteOriginally posted by smc Quote
Great pic..what are you using for a scanner?
Thanks.
I'm using an Epson V500. Actually having a bit of trouble scanning slides. Seems to be a bit of a red cast to most of my scans. I'm fairly new to scanning so I probably just need to work some stuff out.

Swift1
02-13-2010, 11:38 PM   #13
Loyal Site Supporter
SteveM's Avatar

Join Date: Jan 2009
Location: Vancouver Island, BC, Canada
Photos: Gallery
Posts: 3,295
I have tried with a cheap Canon scanner (I have a 67 too), but it has done a horrible job. I don't have the $$ to buy a top end scanner but I'll have to check out the price of the Epson. Great job.

ps...with the 645d I'm having a hard time deciding what to do. Financially I should sell off my 67 gear but 67 was my choice over 645. It's hard...
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
blog, camera, medium format
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
My new blog jezza323 General Talk 21 01-25-2010 05:57 AM
I have a blog now jct us101 General Talk 11 08-16-2009 05:25 PM
I've got a new blog! heatherslightbox General Talk 5 04-21-2009 05:44 PM
My New Blog Tripodman Pentax DSLR Discussion 1 07-12-2008 01:09 PM
new blog what do you think nathancombs Photographic Technique 3 12-06-2007 12:47 PM



All times are GMT -7. The time now is 07:50 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top