Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
  #1
Can I use F, FA and FA J lenses on my *ist D/*ist DS?
Posted By: Ole, 09-07-2006, 09:18 PM

Yes, without any limitations. These lenses are auto-focus and will work in all exposure modes (P, Av, Tv, M, scene modes). The aperture ring on F and FA lenses must be set to "A" at all times. FA J lenses have no aperture ring.
Views: 6,338
02-07-2007, 06:54 AM   #2
Veteran Member
kshapero's Avatar

Join Date: Feb 2007
Location: South Florida, USA
Photos: Gallery | Albums
Posts: 382
QuoteOriginally posted by Ole Quote
Yes, without any limitations. These lenses are auto-focus and will work in all exposure modes (P, Av, Tv, M, scene modes). The aperture ring on F and FA lenses must be set to "A" at all times. FA J lenses have no aperture ring.
Does this mean that the aperture ring will not work with the Pentax Digital SLR's?
02-07-2007, 07:14 AM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,978
Because the Pentax DSLR mounts lack the coupler that can tell how far the lens is stopped down, the aperture ring can't be moved away from "A" without losing auto metering. If you do decide to use the aperture ring, you'll have to manually get the camera to set the shutter speed and aperture as you do with K and M lenses.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

02-28-2008, 07:15 PM   #4
Senior Member




Join Date: Feb 2008
Location: Salt Lake City
Photos: Gallery
Posts: 115
Can someone please tell me why when I put my SMC Pentax-F 35-70mm f3.5-4.5 on my K10D, it not show the Aperture information? (F is blinking.. ..). When I put dial to Av mode, it show shutter speed at 30"?

03-16-2008, 01:10 PM   #5
Senior Member




Join Date: Mar 2008
Location: Lisbon
Posts: 142
AFAIK there are 3 reasons for this to happen:
the aperture ring is not set to "A" and, as Adam said, the camera doesn't know the chosen setting;
there is some dirt in the contacts. In this case try cleaning them and try again;
there is something realy wrong with the lens and it might need a repair.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, fa, lenses, modes
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lenses for *ist DS Kemara Troubleshooting and Beginner Help 3 09-15-2011 10:14 AM
M lenses stop-down meter with *ist D? Dubesor Pentax DSLR Discussion 18 11-11-2010 08:19 PM
*ist D + M42 and M Lenses? Dubesor Pentax DSLR Discussion 4 05-22-2010 04:49 AM
Can I use smc Pentax-A lenses on my *ist D/*ist DS? Ole Pentax DSLR and Camera Articles 3 05-18-2007 10:23 PM



All times are GMT -7. The time now is 03:20 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top