Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-14-2010, 08:36 PM   #1
Inactive Account




Join Date: May 2010
Location: Texas
Posts: 15
USB connection

I've had my k-x for a couple weeks now and just today when I went to transfer some pictures I had to hold the cord at the camera. It was like it wasn't making a good connection. Anybody else have this issue?

06-15-2010, 01:25 AM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,978
USB cords can get worn out, but this shouldn't be an issue if the cord is relatively new. Did you hit, bend, or somehow damage yours on accident?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

06-15-2010, 01:42 AM   #3
rkt
Senior Member




Join Date: Oct 2009
Location: Germany
Posts: 154
Typically the USB cable should fit snugly at the port on the camera ... but since you mention that it doesn't, I would seriously consider transferring pictures by taking the card out and into a card slot or reader of some sort ... this may be a safer strategy in the long run as well ... as you don't need to monitor the battery levels etc when you want to copy over the pics ...
06-15-2010, 03:39 AM   #4
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,679
Indeed the simple solution is to no longer rely on the camera-USB connection and go straight to an SD card reader - saves time and hassle.

It may also depend on your operating system, and whether the camera mode has changed in terms of the USB connection.

06-15-2010, 07:05 AM   #5
Pentaxian




Join Date: Sep 2007
Location: Bay Village, Ohio USA
Posts: 1,026
QuoteOriginally posted by sub5runner Quote
I've had my k-x for a couple weeks now and just today when I went to transfer some pictures I had to hold the cord at the camera. It was like it wasn't making a good connection. Anybody else have this issue?

Does it look/feel as if the cord connector is bad, or the camera connector? Some earlier Pentax cameras, such as the K10D, are known to have a weak physical connection of the USB socket. It is only held onto the internal circuit board by the solder connections for the electrical contacts. Rough handling (or one good whack) of the USB cable can dislodge the socket from the circuit board.

If this has happened, it should be covered by the warranty, especially after only a couple of weeks.

As others have suggested, use a card reader instead of the USB cable. I haven't used the cable with my K10D in three years. Besides, it saves batteries.

OTOH, if its the cable, just try a different cable. They are not proprietary. You can get them anywhere.
06-15-2010, 10:42 AM   #6
Veteran Member
subeeds's Avatar

Join Date: May 2010
Location: Camden County, Ga.
Photos: Gallery
Posts: 333
I've have not had any issues connecting to my laptop. I used it 3 or 4 times so far.
06-15-2010, 07:13 PM   #7
Inactive Account




Join Date: May 2010
Location: Texas
Posts: 15
Original Poster
Thanks for the replies.
Don't have any other cables on hand to try. It fits snuggly but the whole connection seems to wiggle a bit.
That's what I was thinking I'd just use a card reader instead.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, connection, pentax help, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disconnected camera w/out ejecting and now NO USB connection imno007 Troubleshooting and Beginner Help 11 05-29-2010 09:26 AM
usb mini USB for 20D and K-7 sevee Troubleshooting and Beginner Help 7 08-27-2009 09:01 PM
Download: Remove SD card or plug in USB connection? laissezfaire Pentax DSLR Discussion 40 12-16-2008 10:41 AM
What connection .... Trawlerman Pentax Camera and Field Accessories 2 09-20-2007 06:24 AM
USB connection problem..K100D arbutusq Pentax DSLR Discussion 6 12-28-2006 09:19 PM



All times are GMT -7. The time now is 03:27 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top