Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-25-2010, 12:58 PM   #1
Veteran Member
netuser's Avatar

Join Date: Oct 2008
Location: Azores Islands, Portugal
Photos: Gallery
Posts: 2,241
K-7 exposure dial not going down? Help please

Hi all

So, just notice right now that on M mode for instance, dialing the exposure dial UP (front dial/wheel to the right) it works perfectly. On the other way, going down (front dial/wheel to the left) it goes erratic like for instance 1/200 -> 1/100 -> 1/320 etc, instead of going always down

Dial is broken? (think so ) or is there something in the camera that makes this behaviour "normal"? (dialing left mainly makes the exposure go forward .... until 8000)

Urgent help needed!!!

Thanks ins advance

07-25-2010, 01:10 PM   #2
Pentaxian
aleonx3's Avatar

Join Date: Jul 2007
Location: Brampton, Ontario
Photos: Gallery | Albums
Posts: 3,911
QuoteOriginally posted by netuser Quote
Hi all

So, just notice right now that on M mode for instance, dialing the exposure dial UP (front dial/wheel to the right) it works perfectly. On the other way, going down (front dial/wheel to the left) it goes erratic like for instance 1/200 -> 1/100 -> 1/320 etc, instead of going always down

Dial is broken? (think so ) or is there something in the camera that makes this behaviour "normal"? (dialing left mainly makes the exposure go forward .... until 8000)

Urgent help needed!!!

Thanks ins advance
Very likely you had bracketing on.... you should be fine once bracketing is off.
07-25-2010, 02:58 PM   #3
Veteran Member
netuser's Avatar

Join Date: Oct 2008
Location: Azores Islands, Portugal
Photos: Gallery
Posts: 2,241
Original Poster
Bracketing is/was off
07-25-2010, 03:00 PM   #4
Site Supporter
Site Supporter
SpecialK's Avatar

Join Date: Dec 2006
Location: So California
Photos: Gallery
Posts: 14,967
QuoteOriginally posted by netuser Quote
is there something in the camera that makes this behaviour "normal"?
No, there is not.

07-25-2010, 04:57 PM   #5
Site Supporter
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,418
Switch the functionality between front and rear dials in the menu. If it works from rear dial, you then have a problem.
07-25-2010, 11:26 PM   #6
New Member




Join Date: Jul 2010
Location: Guam U.S.A.
Posts: 4
Try the turning the Lens correction/aberration off. As well as the highlight/shadow correction. It's worth a try...
07-26-2010, 12:05 AM   #7
Veteran Member
future_retro's Avatar

Join Date: Jun 2010
Location: Western Washington
Posts: 572
I have the exact same erratic behavior with my DX grip, that's really odd it's happening with the dials on the actual K7 though.
07-26-2010, 02:12 AM   #8
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,401
what is the condition of the camera battery?

I have found on the K7 that the exposure dial processing is a little eratic when the battery is low

07-26-2010, 11:20 AM   #9
Veteran Member
netuser's Avatar

Join Date: Oct 2008
Location: Azores Islands, Portugal
Photos: Gallery
Posts: 2,241
Original Poster
QuoteOriginally posted by hyperboost671 Quote
Try the turning the Lens correction/aberration off. As well as the highlight/shadow correction. It's worth a try...
Quite "funny" but I had turned ON the highlight/shadow correction during the afternoon.....

QuoteOriginally posted by Lowell Goudge Quote
what is the condition of the camera battery?

I have found on the K7 that the exposure dial processing is a little eratic when the battery is low
The battery was not fresh but it's still the same and today the problem is gone.

What I did was to turn on and off after a complete RESET on the camera AND also I turned off the highlight/shadow correction.

After that and during today I tryied again the highlight/shadow correction and there was no problem (battery still the same)

One thing is sure, there is an issue .... with highlight/shadow correction, or battery that might occur again ...


THANKS ALL for the prompt replies
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, exposure, front, instance, pentax help, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sun Dial tpeace Monthly Photo Contests 2 01-10-2010 05:01 AM
What is your e-dial default? jjay Troubleshooting and Beginner Help 7 03-11-2009 10:37 PM
Can I change out the Exposure Compensation Dial? Catelin Troubleshooting and Beginner Help 2 02-09-2009 01:39 PM
GBH just a few-dial up warning borno Post Your Photos! 8 06-11-2008 03:12 AM
Night photography with K10D - High ISO short exposure VS Low ISO long exposure pw-pix Pentax DSLR Discussion 10 02-03-2008 01:37 AM



All times are GMT -7. The time now is 11:40 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top