Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-14-2010, 12:25 PM   #1
New Member




Join Date: Aug 2010
Location: Brasilia
Posts: 3
Hello from Brazil - K20D Damaged?

Hi all,
I've been a Pentax user since 1995, when I bought my K-1000, a Pentax 50mm and 80-200 lenses.
In 1999, I bought a Sigma 28-80 lens and I used them a lot, until 2009, when I could finally upgrade to a K20D! It really rocks.
But this honeymoon last until last week, when It dropped on the floor and now when I turn it on, it keeps complaining of low battery and just shut down, even tryed 3 different batteries (yes, all charged)...
Brazil only has 2 Pentax official repair service (International Service Network (America) : Support & Service : PENTAX), and they are all at Sao Paulo. So, I'll have to wait until I travel to Sao Paulo to get it checked and maybe fixed (I'm not going to send it through mail or something!).
Until then, I'm with an old Sony Cybershot DSC-P10 that I only use for diving (with a marine pack)... I'm sad!
So these are my equipements/accessories:
- K20D&K1000
- Pentax DA 18-55,Pentax 80-200, Sigma 28-80, Pentax 50mm, Flash AF160SA, Pentax Cable Switch CS-205
- Hoya Cir-Polarizing 55mm, Tiffen Color Grad ND 55m, Hoya Cir-Polarizing 49mm, Tiffen 52A, Tiffen 81A, Tiffen 11 Green
- Lowepro Flipside 300, Manfrotto 190XDB Tripod, Manfrotto 486RC2 Ball Head, Targus TG-MP6710 Monopod
Hope to hear from you!

08-14-2010, 12:31 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,993
It sounds like there might be a loose connection in your camera. Do you not want to risk having your camera disappear in the mail?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-14-2010, 01:08 PM   #3
New Member




Join Date: Aug 2010
Location: Brasilia
Posts: 3
Original Poster
QuoteOriginally posted by Adam Quote
It sounds like there might be a loose connection in your camera. Do you not want to risk having your camera disappear in the mail?
My one year warranty has expired, and mailing my camera is expensive and maybe risky (with mail handling and specially with the service support). I really don't know them, and since I have a chance of travelling to Sao Paulo on next two weeks, I prefer to wait.
I have already opened the lower part of the camera to check, and I couldn't find any visible loose connection, maybe it's deeper inside.
Thanks for replying and fixing the post title and links.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50mm, camera, hoya, k20d, manfrotto, pentax, pentax help, photography, sao, service, tiffen
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello, from Brazil Akira_sp Welcomes and Introductions 3 08-20-2009 02:05 PM
New from Brazil Jalapao Welcomes and Introductions 6 05-30-2009 01:02 AM
Brazil aamir515 Post Your Photos! 7 03-20-2008 08:39 AM
Hello from Brazil! albertgr Welcomes and Introductions 4 01-09-2007 06:03 PM



All times are GMT -7. The time now is 05:40 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top