Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-16-2010, 06:27 AM   #1
New Member




Join Date: May 2008
Location: NYC
Posts: 19
Pentax K7 artifact problem

I've got a Pentax K7 which I've been using for months but I just noticed these image artifacts when I super zoom into photos. They seem to be crosses and circles. Usually blue but also green, yellow, and red.

What the heck happened? Do I need a cleaning? repair? or is it a problem with the camera?

I'm attaching samples from 3 separate images taken indoors and outdoors.

Attached Images
 
View Picture EXIF
PENTAX K-7  Photo 
View Picture EXIF
PENTAX K-7  Photo 
09-16-2010, 06:40 AM   #2
Veteran Member
RBellavance's Avatar

Join Date: Nov 2006
Location: Near Montréal, Canada
Photos: Gallery
Posts: 1,716
These look like dead pixels to me. Not sure why you have so many. The K-7 has a menu option to map them out of images (i.e. the camera will interpolate around them).

Or you could send your camera in for service, you seem to have a lot of them. I have yet to notice one in my shots after more than a year with my K-7...
09-16-2010, 07:25 AM   #3
New Member




Join Date: May 2008
Location: NYC
Posts: 19
Original Poster
Yeah I've had mine for almost a year and there's maybe 15 or so of these things that I've counted (so far). I just tried the 'Pixel Mapping' feature you spoke of and it seems to have worked. Thanks much. If I go to get it serviced can they actually fix the dead pixels?
09-16-2010, 09:06 AM   #4
Veteran Member
RBellavance's Avatar

Join Date: Nov 2006
Location: Near Montréal, Canada
Photos: Gallery
Posts: 1,716
They can't fix the dead-pixels any better than you did. What they can do is replace the sensor (or the whole camera) if they determine that it is defective.

If pixel mapping solved the problem for now, good. But I'd keep a close eye on things to see how it evolves in the next few months.

09-16-2010, 10:46 AM   #5
Veteran Member




Join Date: Aug 2007
Photos: Gallery
Posts: 1,563
What firmware are you on?
The early firmware releases are know for stuck and hot pixels.
Install the latest firmware and then map out the pixels using the camera menu.

- Bert
09-16-2010, 08:37 PM   #6
New Member




Join Date: May 2008
Location: NYC
Posts: 19
Original Poster
always the latest firmware. I read dpreview every week and update firmware immediately whenever they get released. Well, since the mapping worked I will leave it at that. I'm just grateful you guys were able to help me so quickly!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k7, pentax, pentax help, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Misc Artifact from the past Johnny5 Post Your Photos! 1 07-02-2010 02:13 AM
edge artifact & moire with K20D... janosh Digital Processing, Software, and Printing 9 11-03-2009 10:03 AM
what is this image artifact eyou Post Your Photos! 7 03-11-2009 02:50 PM
Image artifact madphys Pentax DSLR Discussion 20 01-03-2009 08:03 PM
artifact correction via photoshop gpaual Digital Processing, Software, and Printing 2 01-07-2008 08:44 PM



All times are GMT -7. The time now is 12:12 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top