Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-11-2010, 08:15 PM   #1
New Member




Join Date: Oct 2010
Location: Melbourne
Posts: 9
Preview taking a few seconds to appear

Hello all. Not sure if this is the right place. I have a Pentax K7. When I take photos using my Sigma 17-55 lens, the photo displays instantly on the Preview panel. When I use my Pentax 55-300mm lens in auto mode, same. But when I put it in "P" mode it takes about 3-4 seconds. Any hints?

10-11-2010, 08:30 PM   #2
Pentaxian




Join Date: Sep 2007
Location: La Crescenta, CA
Posts: 7,452
QuoteOriginally posted by akovach Quote
Hello all. Not sure if this is the right place. I have a Pentax K7. When I take photos using my Sigma 17-55 lens, the photo displays instantly on the Preview panel. When I use my Pentax 55-300mm lens in auto mode, same. But when I put it in "P" mode it takes about 3-4 seconds. Any hints?
Do you have distortion/chromatic aberration correction enabled?
10-11-2010, 08:31 PM   #3
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,109
Is it possible you have lens corrections enabled?

Darned Americans, always faster with stuff...
10-11-2010, 09:20 PM   #4
Pentaxian




Join Date: Sep 2007
Location: La Crescenta, CA
Posts: 7,452
That's a first, Wheatfield complimenting an American.



10-12-2010, 08:00 AM   #5
Senior Moderator
Loyal Site Supporter
Parallax's Avatar

Join Date: Apr 2008
Location: South Dakota
Photos: Gallery
Posts: 15,548
QuoteOriginally posted by deadwolfbones Quote
That's a first, Wheatfield complimenting an American.

Are you sure he meant it as a compliment?
10-12-2010, 08:17 AM   #6
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,109
I don't know where you guys get these ideas about me.
10-12-2010, 03:47 PM   #7
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,518
QuoteOriginally posted by akovach Quote
Hello all. Not sure if this is the right place. I have a Pentax K7. When I take photos using my Sigma 17-55 lens, the photo displays instantly on the Preview panel. When I use my Pentax 55-300mm lens in auto mode, same. But when I put it in "P" mode it takes about 3-4 seconds. Any hints?
It is not usual, unless you have a lot of in-camera processing:
- lens correction distortion,
- high ISO correction,
.....

The earlier posts pointed nicely that the likely culprit is the lens correction distortion, because only the Pentax Lenses are recognised by K-7/K-x bodies for lens distortion correction. Even if you select lens distortion correction, with the Sigma, the camera body does not recongise the sigma lens and will not apply the correction.

I may add that 3-4 s is a really long delay. With my K-7, the lens-distortion correction takes less: about 2 s.

Hope that the comment will help.
10-12-2010, 10:40 PM   #8
New Member




Join Date: Oct 2010
Location: Melbourne
Posts: 9
Original Poster
Thanks Chaps. I'm going to have a play this weekend, so will let you know what comes of it. Maybe I should just re-set everything.

10-13-2010, 12:52 PM   #9
Veteran Member
KxBlaze's Avatar

Join Date: Feb 2010
Location: California
Photos: Gallery
Posts: 1,594
If you do re-set everything be sure to go through your options menu. Some corrections and adjustments might be turned on by default. Also if you turned on the copywrite info that will take extra time to load a preview.
10-14-2010, 02:08 AM   #10
Veteran Member
DaveHolmes's Avatar

Join Date: Jul 2010
Location: Yorkshire
Posts: 1,501
Is lens correction something that should be turnned on permenently?

On th K-x in the menu under 'Lens Correction' there are 2 boxes to tick... one labelled 'Distortion Correctin' and the other 'Lat-Chromatic-Ab Adj'

If they don't need to be 'ticked' permenently... When is it appropriate to use them?
10-14-2010, 04:52 AM   #11
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,518
QuoteOriginally posted by DaveHolmes Quote
Is lens correction something that should be turnned on permenently?

On th K-x in the menu under 'Lens Correction' there are 2 boxes to tick... one labelled 'Distortion Correctin' and the other 'Lat-Chromatic-Ab Adj'

If they don't need to be 'ticked' permenently... When is it appropriate to use them?
Dave,

The corrections are relevant/important if you use a zoom lens that is known to havve some distortion. For example, my DA18-250mm is konw for distortions but this is normal considering the huge range of the zoom. On the other hand, a prime lens does not have typically any distortion: for example, my Voigtlander Nokton 58mm lens induces less then 0.1% distortion.

The main reason for my suggestion is lined with the time for the camera body to correct the shot. It is too long if you want to take quickly another shot in a dynamic situation.

I would recommend that you turn off both boxes.

You can always PP (post-process) the photographs with PDCU (Pentax Digital Utility Camera) or any PP softwares.

Hope that the comment will help.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, lens, mode, pentax, pentax help, photography, preview
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Macro 20 seconds....(not for you arachnophobics!) Rense Post Your Photos! 13 08-09-2010 03:21 AM
Landscape 10 seconds to get it right Eastern Shore Charlie Post Your Photos! 17 01-24-2010 08:13 AM
How not to die in 15 seconds .... daacon Post Your Photos! 30 09-26-2009 07:45 AM
Most precious 5.5 seconds falconeye General Talk 10 03-04-2008 07:46 PM
Five Sixteen and Fourteen Seconds Mike Cash Post Your Photos! 1 12-04-2007 04:46 AM



All times are GMT -7. The time now is 11:18 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top