Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-22-2010, 12:58 PM   #1
Forum Member




Join Date: Sep 2010
Location: Czech Republic, Brno
Photos: Albums
Posts: 77
SMC FA 50mm 1.4 question

HI All,

I have just bought a SMC FA 50mm 1.4 and I noticed something strange. The lens is working just fine, however to me it seams the aperture ring doesn't work or probably I'm missing something here. If the lens is not attached to my K-x the aperture ring is working and I can see the blades closing and opening. However when I attach it to the K-x the aperture blades are fully opened. I believe this should be fine as well. Shooting in Automatic aperture works fine, but when I decide to use the aperture ring and to set manually some aperture all photos are anyway made @ 1.4.

Could you please advise if that's a correct behavior?

Thanks,
Tiho

10-22-2010, 01:01 PM   #2
Veteran Member




Join Date: Apr 2008
Location: Minnesota
Photos: Gallery
Posts: 1,530
If the Kx is anything like my K100DS you will need to enable the use of the Aperture ring through a custom setting in the configuration menu.
10-22-2010, 01:01 PM   #3
Veteran Member
wlachan's Avatar

Join Date: Sep 2006
Location: Canada
Photos: Albums
Posts: 2,626
This is normal because Pentax dropped the aperture ring since the digital era. However, Pentax DSLRs still allow the use of aperture rings though the custom menu setting.
10-22-2010, 01:08 PM   #4
Forum Member




Join Date: Sep 2010
Location: Czech Republic, Brno
Photos: Albums
Posts: 77
Original Poster
Excuse my stupidity I had the use of the aperture ring set to on but wasn't shooting using the Manual Mode

Cheers

10-22-2010, 01:16 PM   #5
Site Supporter
pschlute's Avatar

Join Date: Mar 2007
Location: Surrey, UK
Photos: Gallery
Posts: 703
If you are using a lens with an "A" setting on the aperture ring, leave it set to "A" and use the camera dials to set the aperture. This way you will have full exposure control the same as with a DA lens.
10-22-2010, 03:21 PM   #6
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
QuoteOriginally posted by tichomir Quote
Excuse my stupidity I had the use of the aperture ring set to on but wasn't shooting using the Manual Mode

Cheers
Once you take the lens off of A, in anything but manual mode (M), the lens will shoot wide open regardless of the aperture ring setting.

10-22-2010, 11:41 PM   #7
Forum Member




Join Date: Sep 2010
Location: Czech Republic, Brno
Photos: Albums
Posts: 77
Original Poster
thanks for the suggestions guys. everything clear now.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50mm, aperture, blades, camera, fa, k-x, lens, pentax help, photography, smc, smc fa 50mm
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: K-mount Tamron-F 2x Pz-AF BBAR MC7 TC, TWO 50mm SMC-M F1.4, and a 50mm SMC-A F pxpaulx Sold Items 11 06-14-2010 07:42 AM
Asahi smc 50mm F/2 question kyubi01 Pentax SLR Lens Discussion 1 02-23-2010 12:12 AM
Pentax SMC DA* 16-50mm question Burgerbrater Pentax SLR Lens Discussion 14 09-28-2009 07:05 PM
For Sale - Sold: SMC 50mm, SMC 50mm, Tokina RMC 28mm bri_n_m Sold Items 3 06-20-2009 12:27 AM
Question about old 50mm SMC A 1.7 Hannican Pentax SLR Lens Discussion 2 12-13-2007 09:57 AM



All times are GMT -7. The time now is 01:26 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top