Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-25-2010, 03:04 AM   #1
Inactive Account




Join Date: Nov 2010
Posts: 3
Pentax ME (not Super) crank/rewind problem

Hey,

I just purchased a Pentax Me. After some film loading issues, I shot a roll successfully. Rewound correctly and the photos developed.

Now my advance crank has no tension -- and I can't load another roll of film into it. My rewind button seemed normal, and then I pressed it again, and now it looks like it's stuck.

Searched the forums for any answers but didn't seem to find any for the Pentax ME. Any help? I'm in Korea right now and have no real access to any camera shops where they speak English.

Thanks!

11-25-2010, 03:08 AM   #2
Inactive Account




Join Date: Nov 2010
Posts: 3
Original Poster
Just to add -- it doesn't seem as if the mirror is stuck, since I can see through the viewfinder.

Also, the LED light sensor does not work anymore either.
11-25-2010, 04:08 AM   #3
Inactive Account




Join Date: Nov 2010
Posts: 3
Original Poster
Okay, further! I seem to have fixed it by advancing the white spindle by my hand.

Anyone know what the problem is here? I'm worried that this is going to happen in the middle of a roll.
11-25-2010, 10:07 AM   #4
Junior Member
Dangerous Lee's Avatar

Join Date: Nov 2010
Location: Near The Loop
Photos: Albums
Posts: 36
I had a similar problem with my ME Super. I loosened the screws on the base plate (particularly the one below the shutter release) and something made a noise and everything was back to normal. It was probably just dirty and sticky and needed something to help loosen it. I have seen other posts saying that you only need to tap the base plate. It happened to me one other time, and I had to completely remove the base plate and poke around until it reset itself. Been going good for 10 years since then though

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, film, pentax, pentax help, photography, roll
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax Me Super: lost the rewind crank zerotonothing Pentax Film SLR Discussion 12 12-28-2011 09:00 PM
Trying to rewind/remove the film in a Pentax ME Super nady94 Troubleshooting and Beginner Help 7 10-28-2010 12:24 AM
ME Super help - no film advance crank tension, rewind button stuck mclean8 Pentax Film SLR Discussion 2 11-06-2009 07:27 PM
Film rewind problem MeFirstO Pentax Film SLR Discussion 17 07-15-2009 11:26 PM
Advice needed: ME Super rewind button stuck USA2579 Pentax Film SLR Discussion 2 06-24-2009 03:49 PM



All times are GMT -7. The time now is 10:18 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top