Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-07-2011, 10:50 AM   #1
Loyal Site Supporter
bwDraco's Avatar

Join Date: Jul 2010
Location: New York
Photos: Albums
Posts: 1,009
Loss of tactile feedback in some buttons

At least two of the buttons, the up and right directional buttons, on my PENTAX K-r have stopped "clicking" or are softer than normal when they are pressed. The buttons still work, but they just don't feel right. Will the affected buttons eventually fail completely?

Given this and front focusing problems, I'll have to send in my camera for repair under warranty...

--DragonLord

01-08-2011, 06:40 AM   #2
Veteran Member




Join Date: Mar 2009
Location: Chicago suburbs
Photos: Albums
Posts: 848
I would send it in. The loss of 'click' in the buttons would bother me. The FF issue is not good either. Mine front focuses in dim Tungsten light too, although it doesn't seem that bad. I tried with a fast lens (Pentax FA 35mm). It is most pronounced at close focus (as close as the lens would allow). Not really noticeable with the kit lens. Will try the firmware update.
01-08-2011, 07:35 AM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,636
Loss of feedback would probably be normal wear-and-tear after several years, but it's not acceptable on a new K-r. I'd send it in/exchange it.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

01-08-2011, 07:48 PM   #4
Loyal Site Supporter
bwDraco's Avatar

Join Date: Jul 2010
Location: New York
Photos: Albums
Posts: 1,009
Original Poster
Cleaning the affected buttons with a toothbrush seems to have solved the problem, but I am still sending in the camera with a note to check the buttons (and replace the button assembly if necessary) because the problem may recur under normal use. With regard to front focusing, the issue will be obvious if a fast lens such the DA* 55mm f/1.4 lens is used.

--DragonLord

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
buttons, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fn and playback buttons get locked? a101 Troubleshooting and Beginner Help 9 03-02-2010 10:24 AM
Buttons not responding .. ? IsaacSteiner Pentax DSLR Discussion 8 03-21-2009 12:11 PM
Loose buttons on K20d Schwatmann Pentax DSLR Discussion 4 02-27-2009 12:46 AM
Buttons on FA* 28-70mm f2.8 Mojo_fish Pentax SLR Lens Discussion 2 02-12-2008 05:46 AM



All times are GMT -7. The time now is 07:15 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top