Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-11-2011, 06:05 PM   #1
New Member




Join Date: Jan 2011
Location: Wasilla, AK
Posts: 2
Optio M20 light sensor issue

After speaking with a Pentax Tech Rep today over the phone, it seems my Optio M20 may have a light sensor issue on the internal circuit board. I purchased the camera used and the seller was mistaken or misleading about issues with outdoor photography using this camera. No matter what compensation is entered in "Program" using White Balance Shutter Adjustment. EV Adjust or Sensitivity (ISO) settings, outdoor/sun photography is grossly overexposed, "washed-out" over-white images. Placing the camera in "Snow & Sun" mode makes no difference either, yet indoor photography with or without flash works fine.

The tech suggested the light sensor might be faulty. Local repair facilities in my area and the Pentax factory repair fees aren't justified for this more budget-minded camera, yet it's a perfectly usable device and I don't want to toss it in the trash.

I'm very saavy with a soldering gun with respect for circuit boards. Might anyone in the know advise if it's recommended to acquire the needed light sensor part and repair it myself ? I'm willing to give it a try--nothing to loose even if the camera is unrepairable at this point, and I realize doing so could incur needless expense if this isn't the problem with the unit.

thanks

01-12-2011, 05:01 PM   #2
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,484
I know there are people who have ordered parts directly from Pentax. I cannot find the exact info right now. It might be worth a search. You might also try ebay for a parts donor.

Good luck with it..

01-12-2011, 11:30 PM   #3
New Member




Join Date: Jan 2011
Location: Wasilla, AK
Posts: 2
Original Poster
Thanks, that's exactly what I've been doing the past couple days--looking for parts camera.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, issue, light, m20, pentax help, photography, repair, sensor, tech
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K7 - What's the latest with sensor issue? ACobra289 Pentax DSLR Discussion 27 07-20-2009 01:23 PM
Need help with Sensor dust Issue peter sellmer Troubleshooting and Beginner Help 5 01-31-2009 07:24 AM
Problem with Optio M20 cjiveson Pentax Compact Cameras 3 08-26-2008 05:31 PM
Problem with Optio M20 cjiveson Pentax Compact Cameras 0 08-24-2008 11:43 AM
Optio m20...Feeling out of Place here flpoodle Pentax Compact Cameras 5 04-25-2007 06:32 AM



All times are GMT -7. The time now is 09:30 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top