Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-13-2011, 10:35 AM   #1
Junior Member
DonRicklin's Avatar

Join Date: Dec 2008
Location: Worcester, MA
Posts: 29
K-7 Firmware update problem!

I just got the firmware update email and went to do the update on my K-7.
Downloaded. Put it on my SD card in the and followed the instructions for starting the update on my camera. It has been saying
QuoteQuote:
UPDATING


PHASE 1/2
For minutes now, and not the "approximately 90~150 seconds to complete update" quoted from the instructions.

What do I do now????

Don

01-13-2011, 10:48 AM   #2
Veteran Member
RBellavance's Avatar

Join Date: Nov 2006
Location: Near Montréal, Canada
Photos: Gallery
Posts: 1,716
It's not looking good... FWIW, I updated my K-7 earlier and had no problem. It took under 2 minutes.

Has the progress bar moved at all ? I guess you can wait a bit more, but at some point you'll have to turn the camera off and hope for the best (or you can wait until the battery runs out, but the end result will be the same). Unfortunately, there's a big chance it will now be unusable and will require servicing by Pentax.
01-13-2011, 10:51 AM   #3
Junior Member




Join Date: Dec 2010
Location: Norfolk, UK
Photos: Gallery
Posts: 41
Was the memory card freshly formatted or did it have other stuff in the root directory?
I always worry about this happening, it can be expensive and annoying getting it serviced.
01-13-2011, 10:55 AM   #4
Junior Member
DonRicklin's Avatar

Join Date: Dec 2008
Location: Worcester, MA
Posts: 29
Original Poster
QuoteOriginally posted by Monobod Quote
Was the memory card freshly formatted or did it have other stuff in the root directory?
I always worry about this happening, it can be expensive and annoying getting it serviced.
Freshly formatted! No Movement on Bar and battery is quite fresh!

Don

01-13-2011, 11:05 AM   #5
Junior Member
DonRicklin's Avatar

Join Date: Dec 2008
Location: Worcester, MA
Posts: 29
Original Poster
Also posted at K-7 Firmware Update-Help

Since the progress bar seemed not to have moved, I decided to try just turning the camera off! Voila, no upgrade. Not stuck! Whoopy!

But now I am hesitant to try again! Currently running Pentax K-7 1.03!

YMMV

Don
01-13-2011, 11:06 AM   #6
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,678
1.03 > 1.11 can take a while longer than normal because it's a point upgrade. Try formatting the card and running it again - I remember mine took about 5 minutes.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

01-13-2011, 11:12 AM   #7
Junior Member
DonRicklin's Avatar

Join Date: Dec 2008
Location: Worcester, MA
Posts: 29
Original Poster
QuoteOriginally posted by Adam Quote
1.03 > 1.11 can take a while longer than normal because it's a point upgrade. Try formatting the card and running it again - I remember mine took about 5 minutes.
Thanks for the reply! I will try again at home when I can put the camera on the AC adaptor and start fresh with a recopy of the upgrade to another card!

I will post results as I go along!

Don
01-13-2011, 12:56 PM   #8
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,484
Sounds like the update Never got going for some reason. I wouldn't repeat that shutdown experiment if the progress bar has moved (indicating it's working). I understand though. At some point you'll have to shut it off or let it power down regardless of what happens.

FWIW, also, I've NEVER formatted the card before doing the update. I simply make sure that the BIN file is in the right place. That may someday be to my peril but for now, no issues (multiple cameras and updates).



01-13-2011, 01:03 PM   #9
Veteran Member
RBellavance's Avatar

Join Date: Nov 2006
Location: Near Montréal, Canada
Photos: Gallery
Posts: 1,716
QuoteOriginally posted by JeffJS Quote
FWIW, also, I've NEVER formatted the card before doing the update. I simply make sure that the BIN file is in the right place. That may someday be to my peril but for now, no issues (multiple cameras and updates).
I have never formatted the card beforehand either.

Here is what I do:
- copy the firmware file to the SD card (in a card reader on my PC)
- unmount (or otherwise "Safely Remove Hardware") the SD card and take it out of the card reader
- reinsert the SD card in the card reader
- verify that the firmware file has the same checksum on the card and on my hard drive (I use the "md5sum" program on Linux)
- unmount (or otherwise "Safely Remove Hardware") the SD card once more
- insert SD card in camera and upgrade firmware

I have installed every firmware upgrade of the K10D and the K-7 to date using the above procedure, and I have never had a failure.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
firmware, instructions, k-7, pentax help, update
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-7 Firmware Update-Help gilbej49 Pentax DSLR Discussion 22 01-13-2011 10:57 AM
K-7 Firmware update? LDBennett Pentax DSLR Discussion 5 12-30-2010 04:13 PM
K-5 firmware update! goldenzebra Pentax K-5 1 10-30-2010 08:39 AM
Problem with AF after Firmware Update (*istDS) Hambino Pentax DSLR Discussion 2 10-09-2010 05:08 AM
Samsung GX-1S Firmware Update Problem Tim4Peace Pentax DSLR Discussion 1 04-03-2008 03:32 PM



All times are GMT -7. The time now is 05:40 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top