Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-13-2011, 05:52 AM   #16
Senior Member




Join Date: Jan 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 131
Test your SD cards - insert them in your PC/Mac using the built in card reader, or an external card reader that plugs into a USB Port. Format the cards using the computer, and then erase/test the cards, one at a time. After formatting, try writing and reading arbitrary files, like documents or something, on your PC/Mac to convince yourself the cards are ok. The cards will be slower than a hard disk, but should work exactly like any hard disk.

Then insert a card into your camera. Develop a habit of always formatting the card in the camera after inserting a card using the camera menus. This saves you from importing duplicate pictures, and makes sure the camera formats the card how it wants to.

Take some test pictures, remove the card and try reading the pictures into your computer. If this doesn't work, you have a defective camera (because you know the card works fine with your computer) I think most people use a card reader attached to a computer, rather than fumbling around with the supplied camera to computer USB cable.

02-14-2011, 06:25 PM   #17
Inactive Account




Join Date: Feb 2011
Photos: Gallery
Posts: 2
I had the exact same problem with my K-7 and tried 2 different cards but that didn't help. I called Pentax and they suggested that I download the latest firmware - solved the problem! It hasn't happened since. Good luck!
02-17-2011, 11:48 AM   #18
Inactive Account




Join Date: Jan 2011
Location: Galway, Ireland
Photos: Gallery
Posts: 8
Original Poster
Ok guys...thank you so much for all the advice.

I formatted the card, in the camera, as suggested. I could not format the card while in my pc, my pc could not see it.

I also downloaded the new firmwear softwear for the K-7.

I am getting the same problems all the time...'File cannot be displayed'...after only a few shots taken iT sayS 'Memory Card Full'.

Sounds like yet another bad card.....or....

Is it possible that I am just using the camera wrong??
02-17-2011, 01:17 PM   #19
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
If your PC does not see the card, my guess is that it's the card.

I have a USB memory stick that got chewed by my bird At occasion Windows decides that it can't read the stick and offers to format it. If a memory card is anything like a USB stick (I don't have experienced with bad memory cards), the same should happen in my opinion.

02-17-2011, 06:35 PM   #20
Senior Member




Join Date: Jan 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 131
Test your SD cards with PC/Mac as described. If they don't act just like a (slow) disk drive on your PC/Mac, discard the defective cards (or get a refund!) and buy new ones. Do not blame the camera because of defective SD cards. Also, cheap SD to USB card readers can produce results you are seeing.

If the cards do not work with your PC/Mac, cannot be seen, etc, throw the cards away - it's not worth losing good pictures. Name brand 8G cards (Lexar, Sandisk, etc) are about $10-$25 each. Cheap, crappy SD cards, or junk card readers are not worth the hassle, just buy the name brand ones and be done with it.
02-20-2011, 08:12 AM   #21
Inactive Account




Join Date: Jan 2011
Location: Galway, Ireland
Photos: Gallery
Posts: 8
Original Poster
Ok guys...update!!

I went out yesterday morning, took loads of photos. Turned of camera, had lunch, went out again, came home, had dinner and went out again. All day, getting 'File cannot be displayed' and 'Memory Card Full', with the latter, I turned OFF/ON camera and was ok to shoot again. When I was finished and very happy with my days work...I had 3 folders. THEN, while viewing my photos on the camera, I got a 'Memory card full' and then the last folder vanished. Completely gone. WTF??!!

Can this be recovered????

I bought a new card today...when I turned on my camera it displayed 'Memory Card Full' (never been used card)...so I turned OFF/ON camera and went to Format the Card...had to do this 2 times...then I went taking pictures....so far....so good...No problems so far.

What do you think guys???
Is it the camera?
Can I recover the missing folder from old card??

Aisling
02-20-2011, 06:55 PM   #22
Site Supporter
ramseybuckeye's Avatar

Join Date: Apr 2009
Location: Elida, Ohio
Photos: Gallery | Albums
Posts: 8,622
There are several programs that claim they can recover lost files on memory cards. When I had a similar problem due to not formatting a new card, I tried several of these programs to no avail.

I have a hard time believing you could get so many bad cards, I have to think it's the camera, or something you are doing, or not doing.
02-20-2011, 07:07 PM   #23
Pentaxian
twitch's Avatar

Join Date: Nov 2009
Posts: 4,571
Seriously, put that card in the bin, it can never ever be used again. The policy with SD cards should be one strike and you are out.

A couple of weeks ago I had a card go bad on me. Luckily for me I was shooting RAW+JPG as the Mac reovery software can only recover JPGs so I got those back at least. That card went in the bin (it was my only non-SAN disk card too) and bought a new SAN disk card.

So there's a tip for you, RAW+JPG is insurance in case of a bad card.

02-20-2011, 09:55 PM   #24
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
The worrying part is that a new card needed 2 attempts to format. So I would start suspecting the camera and therefor I would definitely have it checked out.
02-24-2011, 01:48 PM   #25
Inactive Account




Join Date: Jan 2011
Location: Galway, Ireland
Photos: Gallery
Posts: 8
Original Poster
Up-date....

Bought another card, a SanDisk SDHC Card 16GB on Sunday... took loads of pictures...and have had NO problems...Thank you God!!!!

Im gonna stick with SanDisk from now on and I hope that is the end of my problems with the camera or I'll be returning the camera.

Thank you ALL so so much for all the advice etc.

Aisling
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, images, pentax help, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K-x Image File numbering avsroy Troubleshooting and Beginner Help 9 03-23-2010 12:45 PM
what price to put on image file? pete_pf Photographic Industry and Professionals 5 01-05-2010 07:09 PM
Error in K200d image file naming jonpitt Pentax DSLR Discussion 6 04-08-2009 10:37 AM
battery failure and file corruption emptydam Pentax DSLR Discussion 0 10-06-2007 01:12 AM
W10 repeating image/file names honestken Pentax Compact Cameras 3 09-11-2007 10:45 PM



All times are GMT -7. The time now is 07:10 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top