Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-07-2011, 03:53 AM   #1
Inactive Account




Join Date: Jan 2011
Location: Galway, Ireland
Photos: Gallery
Posts: 8
Image/File Failure

I bought my K-7 in January and since then I have lost some data. Sometimes when I take a picture and go to view it, it is not there. Two days ago, I was at a concert and I lost over 100 images in one go. They were there upon viewing one minute and completely gone the next. Also, when I plug my camera into my computer, I sometimes get a message saying ‘File not formatted’ but when I turn off/on my camera, I can upload my images. Please help. Why am I losing images???

02-07-2011, 08:09 AM   #2
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
First thought is a bad card. Try another one.

Which make/capacity/class are you using?
02-07-2011, 03:47 PM   #3
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,531
+1 The card

Buy yourself a good quality card like a Sandisk Extreme III. This is worth the investment.

In the mean time, try to recover some files with recovery utility like Recuva, and then re-format the card.
02-07-2011, 11:42 PM   #4
Veteran Member
KxBlaze's Avatar

Join Date: Feb 2010
Location: California
Photos: Gallery
Posts: 1,594
That sounds very odd that photos would just disappear. If it was a bad card it would normally give you an error message (something along the lines of "Image cannot be displayed"), but I cannot think of any other reason besides a bad card. First try and format the card and start from there. If the problem persist than get a whole new card.

02-10-2011, 04:34 PM   #5
Inactive Account




Join Date: Jan 2011
Location: Galway, Ireland
Photos: Gallery
Posts: 8
Original Poster
Hi guys...thank you for your replys.

Ok, the card I am using is a PREMIUM LEXAR 8GB ....I got a new one and now I have 'Image cannot be displayed'.

Shit Card ya?!!
02-10-2011, 04:39 PM   #6
Inactive Account




Join Date: Jan 2011
Location: Galway, Ireland
Photos: Gallery
Posts: 8
Original Poster
EartH
02-10-2011, 05:08 PM   #7
Pentaxian




Join Date: Apr 2007
Location: Oklahoma USA
Posts: 1,502
It's very unlikely to have two bad cards, and the brand you have is very popular.

You should try reading the card externally to the camera, using a card reader, and see if you can recover images using a recovery utility as has been suggested in other posts.

Paul
02-10-2011, 05:24 PM   #8
Site Supporter
ramseybuckeye's Avatar

Join Date: Apr 2009
Location: Elida, Ohio
Photos: Gallery | Albums
Posts: 8,622
You are formatting the cards aren't you? I forgot to once and got these types of happenings.

02-11-2011, 08:36 AM   #9
Inactive Account




Join Date: Jan 2011
Location: Galway, Ireland
Photos: Gallery
Posts: 8
Original Poster
formatting?!! .... am...... how do I do that?? ( Sorry, this is all new to me.)
02-11-2011, 09:23 AM   #10
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
There is an option in one of the menus of the camera. Note that anything that is on the card will disappear.
02-11-2011, 11:58 AM   #11
Veteran Member
KxBlaze's Avatar

Join Date: Feb 2010
Location: California
Photos: Gallery
Posts: 1,594
QuoteOriginally posted by Aholian Quote
EartH
Correct
02-11-2011, 12:27 PM   #12
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,695
See pg 256 of your K-7 manual.
02-12-2011, 03:33 PM   #13
Inactive Account




Join Date: Jan 2011
Location: Galway, Ireland
Photos: Gallery
Posts: 8
Original Poster
Ok, I formated the card...went out, took some photos and STILL got 'File cannot be displayed'.....
02-13-2011, 01:33 AM   #14
Veteran Member




Join Date: Nov 2010
Location: Fife, Scotland
Posts: 834
Got another card you can try?
02-13-2011, 02:27 AM   #15
Veteran Member
KungPOW's Avatar

Join Date: Nov 2007
Location: Vancouver, Canada
Photos: Gallery
Posts: 1,702
Return the camera, keep the card.


Thats right?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, images, pentax help, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K-x Image File numbering avsroy Troubleshooting and Beginner Help 9 03-23-2010 12:45 PM
what price to put on image file? pete_pf Photographic Industry and Professionals 5 01-05-2010 07:09 PM
Error in K200d image file naming jonpitt Pentax DSLR Discussion 6 04-08-2009 10:37 AM
battery failure and file corruption emptydam Pentax DSLR Discussion 0 10-06-2007 01:12 AM
W10 repeating image/file names honestken Pentax Compact Cameras 3 09-11-2007 10:45 PM



All times are GMT -7. The time now is 08:17 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top