Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-14-2011, 03:05 AM   #1
New Member




Join Date: Mar 2010
Location: Krakow
Posts: 4
K20D + Tamron 17-50mm autofocus halts

Hello Pentax People,
First of all I would like to say that I'm also happy pentax camera user since few years, I had been using film cameras, had switched to k10d and currently I am using fantastic camera k20D.

Few months ago I bought awesome lens Tamron 17-50mm f2.8 which was positively reviewed by professionalls. Pictures taken are really sharp and since I attached it to the body it became my favourite lens. But recently I noticed some strange behaviour. When I am focusing with this lens ie. in AF.C mode after few half presses it halts. In AF.S mode the same behaviour. I also notice that AF is not so fast as it was when I bought it. I was testing other lens but it does not stop, it works properly.

Have you ever experince this, or maybe this problem with the body?
Any feedback appreciated
Best regards,
Bartolo

02-14-2011, 06:49 AM   #2
Veteran Member
bimjo's Avatar

Join Date: Jan 2008
Location: Pasco, WA
Posts: 967
Hi Bartolo, welcome to the board.

Have you tried to clean the electrical contacts on the lens with a pencil eraser? It could be that they have become a little bit dirty over time and need to be cleaned. Since you are not having issues with other lenses I would give that a try.

hth
02-14-2011, 07:04 AM   #3
New Member




Join Date: Aug 2009
Location: Cornwall
Posts: 13
my 17-50mm became notchy when testing the focus manually. It would still work but I sent it off for repair anyway. Some 2.50 component had broken or worn out inside. It's back, repaired and works as I expect, pretty good IQ.

Also it has been calibrated for focus and is better than before.

EDIT: they replaced the Focus Drive Coupler

Last edited by dougf8; 02-14-2011 at 01:44 PM.
02-14-2011, 07:13 AM   #4
Veteran Member




Join Date: Mar 2009
Location: Chicago suburbs
Photos: Albums
Posts: 848
The little gold contacts on the lens are just gold plated. Gold plate is very soft, abrasive could wear the gold off eventually. Try a cotton bud (swab) damp with rubbing alcohol, damp not dripping, just a enough alcohol.

02-14-2011, 08:32 AM   #5
New Member




Join Date: Mar 2010
Location: Krakow
Posts: 4
Original Poster
Thank you guys for all your advices
I will test them just when I come back home, I am still at work
02-16-2011, 05:43 AM   #6
New Member




Join Date: Mar 2010
Location: Krakow
Posts: 4
Original Poster
Hello again,
I was cleaning with alcohol lens's contacts and body's as well the behaviour of my tamron is the same. It focuses 5-10 times and freezes, then I cannot see the red AF squere and there is no movement of the lens rings.
@dougf8 did your notchy lens have the same problems?
Thanks in advanced for any answer.
02-16-2011, 02:56 PM   #7
New Member




Join Date: Aug 2009
Location: Cornwall
Posts: 13
No, in all respects the lens was fine. Focus was as it should be. Just with the lens off the camera the focus ring was not 100% smooth. It would snag in a couple of places. I stopped using it pretty quick and sent it off for assessment. The repairer quoted and I agreed. If you don't want the repair you need to pay postage back. So at worst you're looking at 2* freight costs to see (expert repairer) if it is the lens that's wrong. Here in the UK it would have been about 16.

Keep on looking.....
02-16-2011, 03:45 PM   #8
Site Supporter
ChipB's Avatar

Join Date: Nov 2007
Location: Austin, TX area
Photos: Gallery | Albums
Posts: 1,647
Not sure about the Tamron warranty in your country, but the Tamron USA warranty is 6 years. You might consider sending it in for warranty repairs.

02-17-2011, 10:28 PM   #9
New Member




Join Date: Aug 2009
Location: Cornwall
Posts: 13
QuoteOriginally posted by ChipB Quote
Not sure about the Tamron warranty in your country, but the Tamron USA warranty is 6 years. You might consider sending it in for warranty repairs.
5 years in the UK. But I bought 2nd hand and warranty not transferable even if I could remember who I got it from.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
17-50mm, behaviour, body, camera, halts, lens, mode, pentax help, tamron
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: [US] K20D, Metz 58 AF-1 Flash, FA 50mm 1.4, Tamron 17-50mm 2.8, Tamron 18-250m jasonfen Sold Items 11 06-20-2010 06:32 AM
For Sale - Sold: Pentax K20D, FA 35mm 2.0, FA 50mm 1.4, Sigma 12-24mm, Tamron 90mm, D-BG2, TTL imadethis Sold Items 15 02-09-2010 02:02 PM
Refurbed K20D won't autofocus jacquestrapp Pentax DSLR Discussion 10 11-03-2009 02:24 PM
K20D autofocus loud? chse Pentax DSLR Discussion 6 11-10-2008 04:28 AM
K20D AutoFocus. blwnhr Pentax DSLR Discussion 4 02-21-2008 11:34 PM



All times are GMT -7. The time now is 01:13 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top