Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-03-2011, 04:43 PM   #1
Inactive Account




Join Date: Mar 2011
Location: Cape Cod
Posts: 2
istDS, IR converstion.

Hi, everybody ("HELlo, Doctor Nick..")

So I recently purchased a used i*stDS for the specific purpose of converting to IR. Thanks to the tutorials, I was able to easily get to the [EDeleriously tired] IRcut filter, remove it, and replace it with glass.

The shutter works, and focus seems to be fine, (with the clear glass) and all pics so far have come out -ish.

In the process, something seems to have gone awry. There is NO connectivity with the lens, it seems... NO focus confirmation, NO aperture setting or information, NO AUTOFOCUS.

What now?

To answer some pending quesitons:

All program modes read "aperture priority" on the preview screen, except M and B. No aperture or aperture information in ANY mode. Aparrently taking pics WIDE open, with shutter adjustments only. Aside from that, everything else seems to work fine (everything is dead, but other than that...)

I did discharge the flash to my finger a couple times...

I cannot find any wires or connectors that are in any way damaged or that have come detached, in or out

the MF / AF switch engages the motor cam properly, and carries through to the focus rings on the lenses.

manual f ring registers nothing. Nothing in EXiF. See grab below.

THanks for the help.

Attached Images
 

Last edited by iandiam; 03-03-2011 at 05:13 PM.
03-03-2011, 05:28 PM   #2
Veteran Member




Join Date: Mar 2009
Location: Chicago suburbs
Photos: Albums
Posts: 848
I thought that an IR conversion replaced the standard filter with an IR filter, not clear glass. Won't all the light, visible and IR get to the sensor? I thought an IR conversion only allowed IR light to get to the sensor. What am I missing? Sorry, I don't have a clue about the lens problem.
03-03-2011, 05:31 PM   #3
Inactive Account




Join Date: Mar 2011
Location: Cape Cod
Posts: 2
Original Poster
No, you're right. It's actually a not-quite-full spectrum conversion; replace IRcut with clear glass (actually UV filter, but you get the idea.)
03-04-2011, 06:21 PM   #4
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,296
Damn, well done for taking on that task.
Unfortunately you might have zapped something electronic, while handling them circuit boards
Hard to recover from that..

03-10-2011, 09:51 AM   #5
Senior Member
karma mechanic's Avatar

Join Date: Sep 2007
Location: Hampshire, England
Posts: 192
If the flash capacitors discharged while you were doing it there was probably some damage to other components you were touching.

Incidentally, I have a Samsung GX1S which is a rebadged *ist DS (as far as I know) and I'd be interested in following in your footsteps. Apart from the bits that went wrong I mean Do you have a link to the tutorials?
03-10-2011, 10:44 AM   #6
Loyal Site Supporter
bwDraco's Avatar

Join Date: Jul 2010
Location: New York
Photos: Albums
Posts: 1,015
QuoteOriginally posted by iandiam Quote
Hi, everybody ("HELlo, Doctor Nick..")

So I recently purchased a used i*stDS for the specific purpose of converting to IR. Thanks to the tutorials, I was able to easily get to the [EDeleriously tired] IRcut filter, remove it, and replace it with glass.

The shutter works, and focus seems to be fine, (with the clear glass) and all pics so far have come out -ish.

In the process, something seems to have gone awry. There is NO connectivity with the lens, it seems... NO focus confirmation, NO aperture setting or information, NO AUTOFOCUS.

What now?

To answer some pending quesitons:

All program modes read "aperture priority" on the preview screen, except M and B. No aperture or aperture information in ANY mode. Aparrently taking pics WIDE open, with shutter adjustments only. Aside from that, everything else seems to work fine (everything is dead, but other than that...)

I did discharge the flash to my finger a couple times...

I cannot find any wires or connectors that are in any way damaged or that have come detached, in or out

the MF / AF switch engages the motor cam properly, and carries through to the focus rings on the lenses.

manual f ring registers nothing. Nothing in EXiF. See grab below.

THanks for the help.
This means that the camera body is no longer communicating with the lens. I'm not so sure how this can result from IR conversion... Make sure you have not damaged any PCBs, wires, or other electronic components.

--DragonLord
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, focus, glass, information, ir, pentax help, pics, shutter, thanks
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
M42 converstion to K mount John Wiggs Pentax DSLR Discussion 19 04-14-2011 06:03 AM
Still using an *istDS? uccemebug Pentax DSLR Discussion 30 10-31-2010 05:10 PM
New *istDS Owner sajah Welcomes and Introductions 2 03-17-2009 12:20 PM
*istDS Infrared Piotr Pentax DSLR Discussion 4 09-03-2007 06:51 PM
PC control for istDS awjweb Pentax DSLR Discussion 3 03-11-2007 07:25 AM



All times are GMT -7. The time now is 05:22 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top