Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-13-2011, 07:35 PM   #1
New Member




Join Date: Mar 2009
Location: edmonds, washington usa
Photos: Gallery
Posts: 8
ist Ds av problem

ist Ds Camera will not operate the aperture on any lens. get only two flashing lines at any mode setting. Any ideas?

03-13-2011, 07:59 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,091
Enable the use of the aperture ring in your custom function menu. Or, set your lens's aperture ring to the 'A' position.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

09-21-2014, 09:18 PM   #3
New Member




Join Date: Nov 2013
Posts: 4
I have a slightly different problem with my aperture control on my ist Ds. When I set it to Av, it "acts" like the aperture control is working properly...i.e. the scroll wheel sets it in the display to any aperture I choose, and automatically sets the shutter speed accordingly. But it always overexposes if set to any aperture other than the largest aperture. After looking at the properties of some of my photos on my computer, I realized it ALWAYS uses the largest aperture setting of any of three lenses I use. For example, while it may say it is using f22 on the camera, the properties of the photo say it is actually using f5.6. Any help would be appreciated.
09-21-2014, 10:22 PM   #4
Site Supporter




Join Date: Mar 2007
Location: Christchurch, New Zealand
Photos: Gallery
Posts: 482
You don't say what three lenses you are using. That would really be helpful.

If the lenses have an A setting on the aperture ring, set the lens to the A setting. Only lenses with an A setting (and the lens set to A) can have their aperture controlled by the camera.

If your lens has an aperture ring, but no A setting you will need to follow Adam's advice above.

Otherwise you may need to clean the contacts on the lens and the camera to enable successful communication between both on them.

Regards

Chris

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
ds, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
ist DL Problem SamIV Troubleshooting and Beginner Help 5 01-01-2011 11:29 AM
ist DL Problem SamIV Pentax Compact Cameras 1 12-28-2010 03:00 PM
problem with my *ist DL Ne0n730 Pentax DSLR Discussion 2 02-24-2010 10:48 PM
ist-DL problem chromo Pentax DSLR Discussion 18 02-18-2010 03:25 PM
Problem with ist DS bigberg50 Pentax DSLR Discussion 3 10-27-2008 01:10 PM



All times are GMT -7. The time now is 05:56 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top