Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-22-2011, 09:07 AM   #1
Veteran Member
Ansbert's Avatar

Join Date: Apr 2008
Location: Taguig, Phil
Photos: Gallery
Posts: 518
Need help - K7 LCD color display is not working properly

Hi fellow Pentaxian,

My K7 LCD seems to be working weird. The display in "error" is gray like color in (Live View and Preview).

Camera Details:

Firmware version 1.10

How to fix this very annoying error? Any help is greatly appreciated!

Also, it is ok if I downgrade the firmware version of my camera?

Thanks,
Abet

03-27-2011, 07:45 PM   #2
Veteran Member
Ansbert's Avatar

Join Date: Apr 2008
Location: Taguig, Phil
Photos: Gallery
Posts: 518
Original Poster
any suggestion?
03-28-2011, 01:03 AM   #3
Veteran Member
Wombat's Avatar

Join Date: May 2008
Location: South Australia
Photos: Gallery | Albums
Posts: 901
QuoteOriginally posted by Ansbert Quote
Also, it is ok if I downgrade the firmware version of my camera?

Thanks,
Abet
If anything my first suggestion would be to upgrade your firmware.

Is this a problem that's just arisen? Can you give more details of when it happened, what you were doing at the time, has the camera been dropped etc.? Have you checked p.265 of the manual with respect to adjusting the colour of the monitor? (In case your pages are numbered differently, look up "LCD colour tuning" in the index).
03-28-2011, 02:19 PM   #4
Site Supporter
K(s)evin's Avatar

Join Date: Sep 2010
Location: Colorado
Posts: 253
Maybe you accidentally changed your display color. Under Camera menu #3, select Status Screen then go to Display Color. Several to choose from.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, color, display, firmware, k7, lcd, pentax help, version
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Comment Posting Not Working Properly stevebrot Site Suggestions and Help 15 11-22-2010 05:13 PM
MX - B not working properly pontusadefjord Pentax Film SLR Discussion 3 09-13-2010 11:01 AM
How do I know if my camera is working properly? Aegon Pentax Film SLR Discussion 15 05-16-2010 10:56 AM
K20D AF not working properly dgaies Pentax DSLR Discussion 18 03-09-2010 01:15 AM
Pentax K100D Preview display in LCD quit working. mysharonna Troubleshooting and Beginner Help 9 11-23-2009 06:46 PM



All times are GMT -7. The time now is 09:21 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top