Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-04-2011, 06:40 PM   #1
New Member




Join Date: Apr 2011
Location: Ontario
Posts: 15
HHHHHHHelp Flash problems

Can someone help me I don't know what is wrong with my camera. I have a Pentex K100D. I have had this camera for about 8 months and I had bought it used. It has worked great up until yesterday. I was out at this wild life center and I was taking a photo of a snake through a glass when my flash let out a pop when the flash went off and I never got the photo either as it did not take one. (the popping was like the ones from back in the 70's, the ones that were like a cube and had 4 flashes on them). I tried my camera again tonight and it still does the popping sound and it does not take a photo. Can someone help me on this as I live in a small town and I don't have a camera shop near by.

Thank you in advance

newshutterbug.

04-04-2011, 06:45 PM   #2
Pentaxian




Join Date: Feb 2009
Location: Alameda, CA
Posts: 3,198
QuoteOriginally posted by newshutterbug Quote
"it still does the popping sound and it does not take a photo"
I don't know if I can help yet, just need to clarify:

- Does the flash fire?
- Does the camera take a photo, and the photo is severely underexposed, or does the camera NOT take any photo at all?
04-04-2011, 06:52 PM   #3
New Member




Join Date: Apr 2011
Location: Ontario
Posts: 15
Original Poster
Yes the flash fires and makes a popping noise when it does fire and no the camera does not take the photo at all.
04-04-2011, 07:46 PM   #4
Site Supporter
enoeske's Avatar

Join Date: Jul 2009
Location: Surprise, Az
Photos: Gallery
Posts: 1,925
Does it take a photo if you don't use the flash? Is it making a popping sound or more of a ziiiiiiiiit sound. It could just be the stroboscopic focus assist and not taking a picture because it hasn't confirmed focus.

04-04-2011, 07:57 PM   #5
New Member




Join Date: Apr 2011
Location: Ontario
Posts: 15
Original Poster
Yes, it will take a photo if you do not use the flash. No, it is a popping sound. I confirmed focus before I try to take the picture. Than when I continue to take the picture the flash goes off and makes a popping sound and no picture. Hope this helps everyone.
04-04-2011, 08:00 PM   #6
Site Supporter
enoeske's Avatar

Join Date: Jul 2009
Location: Surprise, Az
Photos: Gallery
Posts: 1,925
QuoteOriginally posted by newshutterbug Quote
Yes, it will take a photo if you do not use the flash. No, it is a popping sound. I confirmed focus before I try to take the picture. Than when I continue to take the picture the flash goes off and makes a popping sound and no picture. Hope this helps everyone.
Sounds like its not the focus assist then, but lets rule it out. Can you pop up the flash but put the camera in manual focus mode and try taking a picture? This should ensure the auto-focus isn't the cause.

More likely its a defective flash. Sounds like its trying to pre-flash meter for p-ttl but blowing somthing. Then the flash isn't ready for the actual exposure, so the camera won't take the picture.
04-04-2011, 08:14 PM   #7
New Member




Join Date: Apr 2011
Location: Ontario
Posts: 15
Original Poster
I will check this out tomorrow as I am off to bed need to get up and go to work tomorrow. 6am comes pretty quick thanks so far will let you now more tomorrow.

thanks

newshutterbug
04-05-2011, 07:11 PM   #8
New Member




Join Date: Apr 2011
Location: Ontario
Posts: 15
Original Poster
Hi everyone and thank you for all of your help so far. I have put the camera in manual focus mode and tried taking a picture. The flash still made a popping sound but it did take the picture with or with out the flash.

04-06-2011, 03:38 PM   #9
Site Supporter
GeneV's Avatar

Join Date: Oct 2008
Location: Albuquerque NM
Photos: Albums
Posts: 9,775
The popping sound seems to me like the flash firing at full strength as in with a manual lens.

When you say it never takes a photo, are you saying the shutter does not fire, or just that there is no image? Have you tried with the exposure set to manual?
04-07-2011, 06:40 PM   #10
New Member




Join Date: Apr 2011
Location: Ontario
Posts: 15
Original Poster
GeneV I am not sure if the shutter is working or not when the flash goes off. All I see in the display screen on the camera is black. If could have taken a black picture. When ever the flash pops it startles me and makes me jump. Even though I know it is going to happen. I have not used the camera much since this has started as I don't want to damage it any more than what it is right now. I am looking for a person in my area that can/does work on cameras that does not send them out. I am asking around for help at this time.

Thank for your help

newshutterbug.
04-11-2011, 03:24 PM   #11
Site Supporter
slip's Avatar

Join Date: Oct 2006
Location: 2 hours north of toronto ontario canada
Photos: Gallery | Albums
Posts: 3,533
does the camera lock focus when this happens or is it trying to "find" the subject. try shooting into a mirror and see if you can see if the flash fires at the same time as your shutter clicks. try using P mode as the flash works fully auto in this mode.
My wife has the K100 but I can never seem to find any batteries for it or I would try it out to see if I can help with the problem.

let me know how you make out, I will see if I find batteries to look in her menu

cheers
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, flash, pentax help, photo, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Flash problems, I know im missing something... SlickYamaha Flashes, Lighting, and Studio 19 03-31-2011 11:01 AM
Sigma flash problems SlickYamaha Troubleshooting and Beginner Help 14 02-21-2011 01:29 AM
Help I have flash problems katie Flashes, Lighting, and Studio 11 12-18-2010 11:01 AM
Problems with AF assist on Flash JohnKSA Troubleshooting and Beginner Help 2 03-12-2010 12:07 AM
K200D flash exposure problems valhallasw Pentax DSLR Discussion 4 05-13-2009 05:43 PM



All times are GMT -7. The time now is 06:50 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top