Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-15-2011, 09:28 PM   #1
New Member




Join Date: Nov 2010
Location: kailashahar,TRIPURA
Posts: 4
problem with e-dial of k-x,please help the noob

Hello all,i am in trouble with the e-dial of my pentax k-x, 5 months old.it has been fantastic so far.recently i have a problem.whenever i try to change the value of shutter speed/aperture/sensitivity/EV, it skips the steps.for example when i am trying to change the AV value from 4.5 to 5,it is jumping to 8,10 or higer etc.!then when i try to dial down,it further goes up!the same is happening with the zooming in and out in the playback mode.from x1.8 it is jumping directly to x14, x16 etc. when i rotate the dial one step. I have limited internet access and not able to update and learn from the forum regularly.any prompt suggestions/ideas can really help me.thank you.

04-16-2011, 07:07 AM   #2
Senior Member
HEEGZ's Avatar

Join Date: Jun 2010
Location: Missouri
Photos: Albums
Posts: 258
Try using a rocket blower all around the e-dial. I've not had this issue, but I've read that dust can get in on the contacts and cause the dial to behave strangely. If this is the case, hopefully you can blow the dust out somehow and restore normal function.
04-17-2011, 01:31 AM   #3
New Member




Join Date: Feb 2010
Location: Indiana
Posts: 16
The scroll wheel on my computer mouse does this at times. Scrolling fast or scrolling in one direction no matter which way the wheel turns. It usually has dog hair wrapped around the wheel. Really hard to remove without disassembly. Good Luck
05-07-2011, 11:04 AM   #4
Forum Member




Join Date: Jul 2010
Location: Rosenheim, Germany
Posts: 54
I had same problem on my brand new K-x year ago. Pentax service fixed it free of charge within one day



05-07-2011, 12:15 PM   #5
Loyal Site Supporter




Join Date: Sep 2006
Location: Bronx NY
Photos: Gallery | Albums
Posts: 5,604
The contacts on your e-dial probably need cleaning. BUT...check to be sure that all your other dials, switches, toggles etc are in one position or another, not in between detents. I had a similar problem with my k-x and it turned out to be that the mode dial wasn't quite on Av, once I got it back to it's proper position the e-dial worked perfectly.

NaCl(I think the camera got confused)H2O
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
change, e-dial, pentax help, value
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
*ist DL battery problem (old news I know but I'm a noob) redspecial Pentax DSLR Discussion 32 03-21-2011 07:18 PM
Mode dial problem on K10d Plornt Pentax DSLR Discussion 13 03-16-2011 10:46 PM
k100d mode dial problem song_hm Pentax DSLR Discussion 15 03-14-2011 01:14 AM
Problem with rear dial on K-7 D-BG4 grip, feedback needed/appreciated! pxpaulx Pentax Camera and Field Accessories 4 08-11-2010 10:00 PM
Pentax *ist Selection Dial problem unixrevolution Pentax Film SLR Discussion 5 08-10-2010 06:00 AM



All times are GMT -7. The time now is 01:18 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top