Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-01-2011, 05:09 AM   #1
Inactive Account




Join Date: Jan 2011
Location: Port Elizabeth
Posts: 8
MF film 67 II frame count display issue

Hello everyone

I went out to do star trails last night and, having loaded a roll of Ektachrome 100, I wanted to see how it would handle long exposures.

It was chilly out but nowhere near freezing...every time I fired the shutter the LCD display lost or forgot the frame count number which led me to believe that the camera thought there was a new film in every time the film was advanced.

I used up the remainder of the roll at home and saw that the film was loaded correctly.

Any thoughts on this?

Much appreciated.

Anton

05-01-2011, 12:33 PM   #2
Inactive Account




Join Date: Jan 2011
Location: Port Elizabeth
Posts: 8
Original Poster
Hello Wheatfield

I suspected that due to the relative cold but the batteries are brand new and it did the same on me today on a pleasant warm afternoon.

I reckon something on the camera's insides are not perfectly happy so, unless I am missing something small it will be a no-buy decision...

Cheers,

Anton
05-01-2011, 04:28 PM   #3
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,457
QuoteOriginally posted by antonroland Quote
Hello Wheatfield

I suspected that due to the relative cold but the batteries are brand new and it did the same on me today on a pleasant warm afternoon.

I reckon something on the camera's insides are not perfectly happy so, unless I am missing something small it will be a no-buy decision...

Cheers,

Anton
Check the batteries using a battery tester. New does not always mean good. You might also want to take a look at the contacts in the battery compartment to see if there is obvious corrosion.


Steve
05-03-2011, 02:48 AM   #4
Inactive Account




Join Date: Jan 2011
Location: Port Elizabeth
Posts: 8
Original Poster
QuoteOriginally posted by stevebrot Quote
Check the batteries using a battery tester. New does not always mean good. You might also want to take a look at the contacts in the battery compartment to see if there is obvious corrosion.


Steve
Yep, did that. The camera looks like new, no corrosion there. I think it is maybe a PC board issue.

Will let you guys know if I find anything worth reporting.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
count, display, film, frame, mf film, pentax help, roll, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
67II Frame Spacing Issue RawheaD Pentax Medium Format 10 05-05-2011 10:43 PM
When you open a Film door it resets the shutter count down to 0 right? Abstract Pentax Film SLR Discussion 19 04-30-2011 12:18 PM
LCD Display issue velingara Pentax K-5 7 03-27-2011 07:25 PM
For Sale - Sold: 8, Count 'em 8 Pentax Film cameras and a Lens Too! (Worldwide) JeffJS Sold Items 6 11-19-2010 04:02 PM
K10D frame count BrendanPK Pentax DSLR Discussion 19 03-14-2007 12:12 AM



All times are GMT -7. The time now is 11:08 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top