Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-16-2011, 08:31 AM   #1
Forum Member
Kcjacoby's Avatar

Join Date: Aug 2007
Location: Metro Detroit, Michigan
Photos: Gallery
Posts: 50
K10D and 50mm 1.4 works... K7 and 50mm 1.4... does not work

I'm curious to see if anyone else has had this issue.

I started off with a K10D, and the first lens I purchased was the SMC Pentax-FA 50mm F1.4. I slapped it onto my K10D, and it was a great paring. Had a bunch of wonderful shots with it.. it was great.

However, a few months ago I upgraded to the K7... and once I put it onto the camera to try to duplicate the same results, I soon started noticing some issues with it. In general terms... its short focusing. I'll focus on something, the viewfinder says it is in focus, but once the picture is taken, and I zoom up on the focus point... it is blurry. I've tried the in camera lens adjustment for it, and going to both -10 and +10... it does not resolve the problem.

I was worried that maybe it was damaged, so I put it back onto the K10D, and sure enough, it produces crystal clear photos like it should.

Anyone have any ideas of how I might resolve this issue?

05-16-2011, 02:48 PM   #2
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
Post some test images. Most likely, it is a a simple matter of the the focus sensor covering a larger area than you think, so that sometimes the camera focuses slightly off to the side, above, or below where you see the red dot. That would explain why you can't solve the problem with a simple adjustment. The fact that you never noticed problems on the K10D could be coincidence, or just the fact that the K-7 has enough higher resolution to expose more such problems.
05-16-2011, 07:31 PM   #3
Veteran Member
KxBlaze's Avatar

Join Date: Feb 2010
Location: California
Photos: Gallery
Posts: 1,594
Test photos will definitely help determine the problem. You can also do a controlled focus test. That will let you know if it might be the camera, lens or user.
05-17-2011, 10:23 AM   #4
Veteran Member
Smeggypants's Avatar

Join Date: Sep 2010
Posts: 1,536
I have an FA 50/1.4 0- I've had to calibrate it differently on all my cams. K10D/K20D and now K-5s it did manage to fall within the +/-10 though.

My Pentax A 50mm/f1.2 however does/did require a focus adjustment outside the +/- 10 on all my cams.

Focus screens can't resolve shallow depth of fields below around F2.0 or 2.8, so it's easy to think something is focus when it isn't purely by looking in the viewfinder

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50mm, camera, focus, issue, k10d, lens, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax SMCP-A 50mm f/2.0 work on Kx lovemehate Pentax SLR Lens Discussion 10 10-13-2010 01:19 PM
For Sale - Sold: K10D body, D-BG2 grip, D-BG4 grip, Pentax SMCP-FA 50mm f/1.4, Sigma DC 18-50mm cnote Sold Items 17 07-23-2010 02:40 PM
For Sale - Sold: K10D + grip + 18-55mm, DA 12-24mm, FA 50mm/1.7, D FA 50mm/2.8 macro (Worldwide dgaies Sold Items 6 07-17-2010 03:46 PM
For Sale - Sold: K10D, K20D, Grips, AF-540FGZ, 50mm 1.4, 77mm 1.8, 12-24mm, 16-50mm, 50-135mm + qdoan Sold Items 29 01-13-2010 08:41 PM
For Sale - Sold: DA* 16-50mm f/2.8 - damaged but works normaly heliphoto Sold Items 4 11-24-2009 07:55 PM



All times are GMT -7. The time now is 11:35 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top