Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-28-2011, 06:34 AM   #1
Senior Member




Join Date: Mar 2011
Location: Boca Raton, Florida
Posts: 104
Help! AF not working

Help! I am using a K5 and just bought a used 300/4.5 SMC F...the AF is not working on the 300..manual focus is fine, images are very sharp, but no AF...motor runs in fits and starts, but lens does not move into focus. I've tried dismounting, remounting the lens...won't work. Is there an incompatibility here that I am not aware of?

Any kind of help would be greatly appreciated...very soon, please. I really like this lens and would prefer not to return it for a refund.

Roy Benson

To be more specific: lens is listed in the Pentaxforum database as an F series lens...entitled 300/4.5 SMC Pentax F ED IF. Lens is considered rare and has a user rating of 10. I'd provide a link, but my link thing isn't working. Hope this helps.
Furthermore, the lens has no AF/MF switch...AF/MF must be activated from the K5 camera body.


Last edited by benroy; 05-28-2011 at 08:44 AM. Reason: more info added
05-28-2011, 06:45 AM   #2
Veteran Member
TOUGEFC's Avatar

Join Date: Nov 2009
Location: Brisbane
Photos: Gallery
Posts: 3,561
Whats the exact name of the lens?
05-28-2011, 07:00 AM   #3
Pentaxian
Mike.P's Avatar

Join Date: Mar 2008
Location: South Coast .. UK
Photos: Gallery
Posts: 1,753
Have you moved the ring round the lens to AF?
05-28-2011, 07:04 AM   #4
Senior Member




Join Date: May 2010
Location: Hilversum
Photos: Gallery
Posts: 215
I guess you have a couple of choices. Call the lens busted and send back for refund, or have it checked/fixed professionally and charge the seller for repairs. Is that the FA* 300mm?

(nice)

05-28-2011, 07:05 AM   #5
Senior Member




Join Date: May 2010
Location: Hilversum
Photos: Gallery
Posts: 215
QuoteOriginally posted by Mike.P Quote
Have you moved the ring round the lens to AF?
LOL it would just be as busted if the motor moved while the thing was on MF
05-28-2011, 07:48 AM   #6
Veteran Member
selar's Avatar

Join Date: Jul 2007
Location: Sydney, Australia
Photos: Gallery | Albums
Posts: 2,035
I have one and the motor moves but with difficulty when the ring is set to manual focus. To disable the motor completely the body af switch also has to be set to manual.
05-28-2011, 08:01 AM   #7
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,131
The F300 has the AF/MF switch built right onto the focus ring, no?
Move the ring forwards gives manual focus, backwards AF (or perhaps opposite, mine isn't at my fingertips at the moment).
Anyway, I'd try moving the ring back and forth a few times to see if I couldn't get it to start engaging the AF drive properly.
Otherwise it's repair time.
05-28-2011, 08:48 AM   #8
Senior Member




Join Date: Mar 2011
Location: Boca Raton, Florida
Posts: 104
Original Poster
Non AF for 300

Lens has no AF/MF switch...AF/MF must be activated by the K5 body. Lens is listed in the Pentaxforum lens database as an F series prime lens.

Roy Benson

05-28-2011, 09:57 AM   #9
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
Is it This type of lens? (I know the FL is different)





The focus ring pushes one way for Manual focus and the other way for Auto focus. That is the Lens AF/MF switch people are referring to.

05-28-2011, 11:40 AM   #10
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,131
QuoteOriginally posted by benroy Quote
Lens has no AF/MF switch...AF/MF must be activated by the K5 body. Lens is listed in the Pentaxforum lens database as an F series prime lens.

Roy Benson
A link would be nice. I'll help if I can, but I'm not going to dig around in the database doing what you should be doing.

Ok, the ring behind the focusing ring moves forwards and backwards to switch from AF to MF. If you can't see the words Auto Focus printed on top of the lens, you have the lens in manual focus.

Last edited by Wheatfield; 05-28-2011 at 12:52 PM.
05-28-2011, 02:46 PM   #11
Pentaxian
Mike.P's Avatar

Join Date: Mar 2008
Location: South Coast .. UK
Photos: Gallery
Posts: 1,753
QuoteOriginally posted by benroy Quote
Lens has no AF/MF switch...AF/MF must be activated by the K5 body. Lens is listed in the Pentaxforum lens database as an F series prime
Arrow points to AF/MF switch/ring .. click it forward and backwards for focus.

05-28-2011, 06:11 PM   #12
Senior Member




Join Date: Mar 2011
Location: Boca Raton, Florida
Posts: 104
Original Poster
Thanks, Mike...never thought to try that ring...greatly appreciate your timely message...problem solved.

Roy Benson
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, focus, k5, lens, link, pentax help, smc
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Macro I'm Working! eaglem Post Your Photos! 3 05-21-2010 07:37 AM
K-X sr working? bullwhip Pentax DSLR Discussion 6 01-20-2010 12:44 AM
How to tell if SR is working? slow2focus Troubleshooting and Beginner Help 14 12-21-2009 09:49 PM
survey: batteries working/not working with the K-x noou Pentax DSLR Discussion 25 12-03-2009 02:43 PM
How do you know that SR is working? kitkat Pentax DSLR Discussion 10 07-30-2009 07:55 AM



All times are GMT -7. The time now is 02:33 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top