Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-05-2011, 01:25 PM   #1
Veteran Member
justinr's Avatar

Join Date: Dec 2009
Location: Tipperary
Photos: Gallery
Posts: 394
Software installs then does nothing

I installed the Digital Camera Utility 4 that came with the K5 and it worked OK. However, due to me not being familiar with the software I got in a right muddle (or there was a problem with the software) so I thought I'd reinstall and start from scratch. Have done this but now the programme won't run and I get the message -

'Runtime error

Abnormal programme termination.'

I have also tried opening the RAW files from the K5 in Pentax Photo Laboratory but there the message is 'Failed to preview'

The jpegs of the same shots display fine in Photoshop etc.

Any ideas?

06-05-2011, 04:29 PM   #2
Loyal Site Supporter
imtheguy's Avatar

Join Date: Mar 2009
Location: Virginia Beach
Photos: Gallery | Albums
Posts: 2,950
Would need to see more information to give you a "why" but suggest you uninstall the package, reboot, install again if you have not already. If a clean install does not run as it did the first time, something has changed in your environment and you will need to think about what that might be. (other new software? new hardware? broken uninstall?, etc). See if newer versions or updates are available online to use instead of or to patch the current version. Good luck
06-05-2011, 04:39 PM   #3
Site Supporter
K57XR's Avatar

Join Date: Feb 2011
Location: Colorado, USA
Posts: 828
Try and do a "All files and Folders" search in your system for this file - checkinfo.ini
It will be in a Pentax folder. If you find it you can either rename or delete it.
Hope this helps! Cheers!
06-05-2011, 04:47 PM   #4
Loyal Site Supporter
imtheguy's Avatar

Join Date: Mar 2009
Location: Virginia Beach
Photos: Gallery | Albums
Posts: 2,950
Agreed. If Uninstall does not remove the .ini file.
On Win7 its located in C:/Users/<username>/AppData/Local/Pentax/Digital Camera Utility 4/

06-05-2011, 07:14 PM   #5
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,484
If that doesn't work for you there are always other programs. The undeniable truth, in my experience, is that the PDCU software has always crashed if it started to begin with. That's been true with 4 different versions on 3 different computers running various versions of windows.

06-06-2011, 01:48 AM   #6
Veteran Member
justinr's Avatar

Join Date: Dec 2009
Location: Tipperary
Photos: Gallery
Posts: 394
Original Poster
Many thanks for the fix. I've removed the checkinfo file and it's now working well enough to process a jpeg from the RAW (better image quality than the in camera one) but I can't use the White balance, Lens correction etc functions as the software thinks that all the files are jpegs and won't allow the appropriate boxes to be ticked under the 'Windows' header on the menu.

I am now hopefully out of trouble sufficiently to get the present job done but I'll need to look at it again soon.
06-07-2011, 12:59 AM   #7
Junior Member
Alan Bird's Avatar

Join Date: Jun 2010
Location: Milton Keynes, Buckinghamshire
Posts: 30
Thanks for this information, all. I've had the same problems with this software since I got my K-x a year ago and tried everything I could think of - uninstall, reboot, registry clean etc. I've now renamed the checkinfo.ini file and all is well!

Thanks guys
06-07-2011, 06:41 AM   #8
Site Supporter
K57XR's Avatar

Join Date: Feb 2011
Location: Colorado, USA
Posts: 828
If the check-box is clicked on any of the thumbnail photos and leave it there, the “checkinfo.ini” file is created in the DCU4 folder as the application is closed. If this file is either renamed or deleted for the “fix”, a new one will be created and will cause the same problem.

To prevent the issue from reoccurring, make sure there are no checks in any of the thumbnail photos before closing the program.

06-07-2011, 06:51 AM   #9
Site Supporter




Join Date: May 2011
Posts: 262
QuoteOriginally posted by justinr Quote
Many thanks for the fix. I've removed the checkinfo file and it's now working well enough to process a jpeg from the RAW (better image quality than the in camera one) but I can't use the White balance, Lens correction etc functions as the software thinks that all the files are jpegs and won't allow the appropriate boxes to be ticked under the 'Windows' header on the menu.

I am now hopefully out of trouble sufficiently to get the present job done but I'll need to look at it again soon.
Have you installed the latest update? That might be enough to get it fully workimg again.
The latest update also allows processing of jpeg if it recognises them as being shot with a supported Pentax camera. The problem can be if they are imported with the Windows photo import then they aren't recognised (Import with Windows Live Photo Gallery or PDCU itself and they are ok). I don't know if that might affect RAW files as well.
If all else fails, backup what might be lost to My documents folder or sub-folder and roll back and start again.
I actually quite like PDCU4 because it is dedicated to Pentax and ... free. It was problematic for me for a while until it decided to behave and I've had no crashes from it since (running on Windows 7 64 bit).
The beta of PhotoDirector recognises Pentax RAW files and is ok: PhotoDirector 2011 Beta Version ? Professional Quality Photo Editing Software
Download the beta, review it and the released version is free.
06-08-2011, 12:50 AM   #10
Junior Member
Alan Bird's Avatar

Join Date: Jun 2010
Location: Milton Keynes, Buckinghamshire
Posts: 30
QuoteOriginally posted by K57XR Quote
If the check-box is clicked on any of the thumbnail photos and leave it there, the “checkinfo.ini” file is created in the DCU4 folder as the application is closed. If this file is either renamed or deleted for the “fix”, a new one will be created and will cause the same problem.

To prevent the issue from reoccurring, make sure there are no checks in any of the thumbnail photos before closing the program.

Just found this out the hard way! What a brilliant piece of software design! Thanks for the tip.
06-09-2011, 09:54 AM   #11
Veteran Member
justinr's Avatar

Join Date: Dec 2009
Location: Tipperary
Photos: Gallery
Posts: 394
Original Poster
Many thanks for the help folks but this is proving a tough nut to crack.

I have now cleared out, rebooted and installed the software several times and still the problem of not being able to tick any of the boxes in the 'windows' menu for RAW files persists! I have also downloaded and installed the latest update.

This really is the most uncooperative piece of software that I have come across, or is it me?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k5, message, pentax help, programme, software
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for new PP software interested_observer Digital Processing, Software, and Printing 5 11-14-2010 10:12 PM
Which software do you use? Capslock118 Digital Processing, Software, and Printing 16 11-12-2010 05:02 AM
Software Smolk Pentax Medium Format 4 04-01-2010 07:11 AM
software houstonmacgregor Pentax DSLR Discussion 3 03-19-2010 11:03 AM
Does K-x come with K-7 software? hinman Pentax DSLR Discussion 2 12-03-2009 02:16 PM



All times are GMT -7. The time now is 03:55 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top