Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-11-2011, 06:07 AM   #1
New Member




Join Date: Jun 2011
Posts: 5
Help! Automatic Flash not working consistently

Help! My automatic flash will work for about the first three pictures and then stops working. I just got it back from a professional service for cleaning and to have the flash repaired. They returned it after cleaning the lenses and determined there were no flash problems??? Help! Is there something I can try before taking it back?

06-11-2011, 06:17 AM   #2
Loyal Site Supporter
Loyal Site Supporter
blackcloudbrew's Avatar

Join Date: Mar 2009
Location: Cotati, California USA
Photos: Gallery | Albums
Posts: 3,816
Let's start with some basics, what camera?
06-11-2011, 06:21 AM   #3
New Member




Join Date: Jun 2011
Posts: 5
Original Poster
Oh, sorry...Pentax ist DS
06-11-2011, 06:50 AM   #4
Inactive Account




Join Date: Dec 2008
Location: Ames, Iowa, USA
Photos: Albums
Posts: 2,965
If you are taking photos one right after the other it is common for the flash to take a longer and longer time to recharge - this is usually because the batteries are getting hotter and hotter.

Are you sure you are waiting a long enough time between shots? I suspect not because as you describe the situation, you shoot a few times, it stops working, you put it down for a while, and it starts working again. Therefore something is recovering - it is likely something cooling off (in a broader sense batteries recovering.)

I think you might find that lithium batteries are best from a recycle time standpoint.

06-11-2011, 07:39 AM   #5
New Member




Join Date: Jun 2011
Posts: 5
Original Poster
Yes, I am waiting between taking pictures (even though this never mattered before). I purchased this camera about 5 years ago, new, and never had this problem before. I am also using Energizer lithium batteries.
06-11-2011, 08:41 AM   #6
Inactive Account




Join Date: Dec 2008
Location: Ames, Iowa, USA
Photos: Albums
Posts: 2,965
QuoteOriginally posted by cameramom Quote
Yes, I am waiting between taking pictures (even though this never mattered before). I purchased this camera about 5 years ago, new, and never had this problem before. I am also using Energizer lithium batteries.
Is this the first time you've used these batteries with this result? Could you try different batteries? Or maybe feel theses batteries to see if they are overheating?

I'm not trying to second guess you, just trying to make the symptoms precise; if it isn't the batteries (either by type or these particular batteries) then the fault must be internal.
06-11-2011, 09:45 AM   #7
New Member




Join Date: Jun 2011
Posts: 5
Original Poster
Yes, I tried a different type of new batteries and still had the same outcome.
06-11-2011, 09:50 AM   #8
Inactive Account




Join Date: Dec 2008
Location: Ames, Iowa, USA
Photos: Albums
Posts: 2,965
QuoteOriginally posted by cameramom Quote
Yes, I tried a different type of new batteries and still had the same outcome.
That's pretty good evidence it is internal I'd say.

It might help the fixers if you could give some data - like how many shots before it stops working and how long it takes for it to recover? Or maybe just send it back with a strong note?

Sorry it wasn't something simple - you must be frustrated!

06-11-2011, 11:09 AM   #9
New Member




Join Date: Jun 2011
Posts: 5
Original Poster
Thanks for trying. I will certainly take your suggestion about providing the service company more detailed information
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
flash, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why does Pentax consistently UNDER-EXPOSE and usually under-saturate images? PentaxForums-User Pentax DSLR Discussion 122 07-12-2010 06:14 AM
Flash just stopped working? Eruditass Flashes, Lighting, and Studio 9 07-01-2010 05:49 AM
For Sale - Sold: Metz 54 MZ-4i Digital Fully Automatic 54 GN P-TTL HSS Strobe Flash for Pentax wallyb Sold Items 4 11-12-2009 12:32 AM
Will my automatic NATIONAL PE-243 flash work with my k100D super? FinCanPhoto Flashes, Lighting, and Studio 7 06-04-2008 02:39 PM



All times are GMT -7. The time now is 09:23 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top