Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-22-2011, 04:54 PM   #1
New Member




Join Date: Aug 2007
Location: Ontario, Canada
Posts: 23
K100D problems

Suddenly started today.
It has not been dropped or abused.
Menu will not activate.
Flash will not pop up.
Shutter release will not take a picture when pressed.
In manual mode (M) LCD shows Tv 125 and Av 11 but I am not able to change either of the settings.
In Auto Pic nothing appears in view finder.
The battery shows fully charge. Changed batteries and still shows full charge.
The lens is locked in.
Pushing the Fn button - nothing appears in the screen.
What else can I check to determine if it has to go to a repair shop????

06-22-2011, 05:06 PM   #2
Site Supporter
ismaelg's Avatar

Join Date: Apr 2009
Location: Puerto Rico
Photos: Gallery
Posts: 952
That is a tough one. Check if any button is stuck. That happened to me on a Fuji camera once.
Another thing to check is the SD card. Try without it or with another one.
Have you tried without the lens?
Hope you can solve it.
06-22-2011, 05:56 PM   #3
Site Supporter
slip's Avatar

Join Date: Oct 2006
Location: 2 hours north of toronto ontario canada
Photos: Gallery | Albums
Posts: 3,515
QuoteOriginally posted by sylvanite Quote
Suddenly started today.
It has not been dropped or abused.
Menu will not activate.
Flash will not pop up.
Shutter release will not take a picture when pressed.
In manual mode (M) LCD shows Tv 125 and Av 11 but I am not able to change either of the settings.
In Auto Pic nothing appears in view finder.
The battery shows fully charge. Changed batteries and still shows full charge.
The lens is locked in.
Pushing the Fn button - nothing appears in the screen.
What else can I check to determine if it has to go to a repair shop????
I would get a volt meter to check the output of the batteries. I know with my wife's k100 if the batteries are even a bit down, it starts doing funny things, especially in the winter.
try getting a pencil eraser and rub on the contacts where the batteries touch. sometimes there is a bit of "corrosion" for lack of a better word.
If this doesn't work, if you have the ac cord, plug the camera in and then either update the firmware or re-install the latest.
If that fails, do what I did when my sigma flash wasn't working.... give it a good bang with your hand a couple of times. not sure why it worked, but it worked for me.

good luck
06-22-2011, 06:45 PM   #4
Pentaxian
ryan s's Avatar

Join Date: Jan 2008
Location: Madison, WI
Photos: Gallery
Posts: 2,370
Bang-on-Hand fixes film cameras and a lot of other things

To add in other troubleshooting steps, sometimes leaving the battery out overnight helps. Seems kind of strange, but it can cure cameras, phones, laptops...lots of stuff.

Work the e-dial(s) vigorously--sometimes they can get stuck "between" clicks.

Strange, though...seems like it's half working...at least the mini screen is, sometimes.

06-22-2011, 06:59 PM   #5
New Member




Join Date: Aug 2007
Location: Ontario, Canada
Posts: 23
Original Poster
It is alive.

After changing the batteries for the 3rd time the camera now works.
I'm assuming that it was the batteries all along.
Thanks everyone for your help.
Now I don't have to buy a new Kr. Damn.
Wife is happy though.
So am I as I love this camera.

Thanks again.
06-22-2011, 09:13 PM   #6
Pentaxian
ryan s's Avatar

Join Date: Jan 2008
Location: Madison, WI
Photos: Gallery
Posts: 2,370
Huh. Can you duplicate it with those "bad" batteries reliably? If not, maybe it was an intermittent error...

Well you could always say the K100D stopped working permanently (and I take no responsibility for the recourse of that action ).
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
charge, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K100D Problems pnind Pentax DSLR Discussion 3 06-10-2010 09:24 AM
K100D Shutter/Mirror Problems dub_1211 Pentax DSLR Discussion 2 06-08-2010 06:06 AM
K100D Light Meter Problems interested_observer Pentax DSLR Discussion 4 02-21-2010 02:59 PM
having problems with K100D nathancombs Pentax DSLR Discussion 8 10-10-2008 10:58 AM
K100D problems... leadbelly Pentax DSLR Discussion 2 07-02-2007 04:34 AM



All times are GMT -7. The time now is 05:33 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top