Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-03-2011, 06:29 AM   #1
Loyal Site Supporter
charliezap's Avatar

Join Date: Feb 2009
Location: saugus ma
Photos: Gallery | Albums
Posts: 8,149
Problem with my flash.

I've had my Vivitar 285 HV flash for over 5 yrs.When I now power it up either on camera or off it fires all by itself without me touching anything.Is it time for a new flash.----thanks--charliezap

07-03-2011, 06:47 AM   #2
Site Supporter
Ahab's Avatar

Join Date: Jul 2007
Location: Oracle, Az
Photos: Gallery | Albums
Posts: 739
Yes, it's time.
07-03-2011, 06:52 AM   #3
Veteran Member




Join Date: Mar 2009
Location: Chicago suburbs
Photos: Albums
Posts: 848
Does it work properly after that? If it still works, it's your call, but something is wrong. It should not do that. Are you up to a DIY repair? Make sure you discharge the flash completely before you take it a part. Take many pics as you go (got a macro lens?). They will help when you put it back together. You could buy another and sell this one on ebay as a fix/parts unit.
07-03-2011, 12:09 PM   #4
Pentaxian




Join Date: Sep 2007
Location: Bay Village, Ohio USA
Posts: 1,025
The 285 and 283 share the same hotshoe assembly. It is attached with two screws from underneath. If you remove those two screws, the hotshoe will come off, but remain attached via two thin wires.

Its possible that the two wires have become frayed, or the solder joints that hold them to the metal contacts in the shoe have become loose, and are allowing the wires to short, triggering the flash.

Or, perhaps the metal contacts have become deformed or pushed out of place, causing the same thing.

If you're handy with a soldering iron, you may be able to re-solder the wires to the contacts. New hotshoes are readily available on ebay, for only a few dollars. There is even a metal shoe that you can upgrade to.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
macro flash problem Basler30 Troubleshooting and Beginner Help 4 04-29-2011 07:56 AM
K7 Flash Problem pavtu Pentax DSLR Discussion 3 02-10-2010 10:01 PM
K10D+540 flash problem using trailing flash wirelessly PaulT Flashes, Lighting, and Studio 4 01-18-2010 10:00 AM
Pentax K2000 flash problem...I think 68mpolo Troubleshooting and Beginner Help 5 09-22-2009 09:11 AM
K7 Wireless Flash Problem kckt Pentax DSLR Discussion 9 07-18-2009 08:05 AM



All times are GMT -7. The time now is 05:40 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top