Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-06-2011, 06:39 AM   #1
Junior Member




Join Date: Sep 2008
Location: City of Elliot Lake (North Eastern) Ontario, Canada
Photos: Gallery | Albums
Posts: 44
K5 firing multiple shots. Set on Single frame.

Set on Single frame shooting I am increasingly getting multiple shutter activations.
Sometimes just one added firing sometime up to three.
Sometimes there is an actual picture taken, sometimes not.
I press halfway, pause to focus/anti shake, then follow through with the press.
If I let up quickly one shot only is taken. If I hold down momentarily it may or may not fire 1 or more times.
This is not constant. I can take a couple of dozen shots (or more) without incident.
The extra pictures are not so much the problem but who needs unnecessary activations shortening my camera's life.
Is this a mechanical problem? Is it common?
Any suggestions please.

07-06-2011, 08:25 AM   #2
Veteran Member




Join Date: Mar 2009
Location: Chicago suburbs
Photos: Albums
Posts: 848
Is your K-5 under warranty? If so, send it in. This problem might be in the shutter release switch. Did the shutter button get pushed really hard at any time? You could replace the shutter switch if out of warranty. I replaced the shutter switch in a K200, so it is doable, but not for everyone. I have photos of the repair in my albums.
07-06-2011, 10:25 AM   #3
Site Supporter
Deimos's Avatar

Join Date: Oct 2010
Location: Kingdom of Wonder
Posts: 1,708
I swore I saw some other thread on here about this with a bunch of ppl chiming in the with the same issue. do a couple of searches. not sure if there was any resolution other than to send it in
07-06-2011, 03:47 PM   #4
Pentaxian
twitch's Avatar

Join Date: Nov 2009
Posts: 4,571
Seems as though this issue is the major QC issue for the K-5.

07-09-2011, 08:09 AM   #5
Junior Member




Join Date: Sep 2008
Location: City of Elliot Lake (North Eastern) Ontario, Canada
Photos: Gallery | Albums
Posts: 44
Original Poster
QuoteOriginally posted by gp1806 Quote
Is your K-5 under warranty? If so, send it in. This problem might be in the shutter release switch. Did the shutter button get pushed really hard at any time? You could replace the shutter switch if out of warranty. I replaced the shutter switch in a K200, so it is doable, but not for everyone. I have photos of the repair in my albums.
Nope. Always gentle. And I am still under warranty. Going to hang in for a bit longer and see how it goes before shipping it in. 2 days of shooting with no repeats.
07-09-2011, 08:10 AM   #6
Junior Member




Join Date: Sep 2008
Location: City of Elliot Lake (North Eastern) Ontario, Canada
Photos: Gallery | Albums
Posts: 44
Original Poster
QuoteOriginally posted by Deimos Quote
I swore I saw some other thread on here about this with a bunch of ppl chiming in the with the same issue. do a couple of searches. not sure if there was any resolution other than to send it in
couldn't find any other references.
07-10-2011, 08:03 AM   #7
Site Supporter
Ahab's Avatar

Join Date: Jul 2007
Location: Oracle, Az
Photos: Gallery | Albums
Posts: 739
I too had this happen with my new K5 but after a while it stopped doing it. Now hasn't done it in 7 months.
07-10-2011, 05:42 PM   #8
Pentaxian
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 13,850
My *istD does this sometimes. I found a "solution" of sorts - works well enough. Read here:

https://www.pentaxforums.com/forums/general-technical-troubleshooting/131062-...ble-shots.html

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
activations, pentax help, press, shots
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Single 52-72 step up ring or 52-72 set? geekette Pentax Camera and Field Accessories 11 05-20-2011 09:13 PM
Single Frame Shooting Vs Continuous Drive Mode Verglace Troubleshooting and Beginner Help 5 03-05-2011 08:19 AM
Misc Single in September - surplus shots axl Post Your Photos! 11 09-14-2010 01:13 PM
Macro Single Flower Macro Shots stl09 Post Your Photos! 5 11-15-2009 03:11 PM
Fireworks -- multiple exposure -- single frame konraDarnok Post Your Photos! 2 07-06-2008 04:24 PM



All times are GMT -7. The time now is 02:01 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top