Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-04-2011, 06:48 AM   #1
Junior Member




Join Date: Jul 2011
Posts: 30
Pentax P30 doesn't release the shutter

Hello.

My name is Tom, an I'm new here.

My problem is, I have just received a Pentax P30 body and it doesn't function properly.

Being used to a Zenit SLR i just got the P30 into my hands and pulled the lever to advance the film (with no film inside and no batteries). Then I realized: 'O gosh it has an electronic shutter'. So I loaded the GPA76 (LR44) batteries, unfortunately, reversed. I turned the computer on, looked for the manual, and then placed the batteries properly. I turned the camera on, but there was no information in the viewfinder displayed. I accidentaly pushed the Memory Lock button and then everything appeared. Selected shutter speed appeared in the viewfinder.I pushed the shutter button all way down and the shutter didn't release.

Then, after a few seconds, all information dissapeared and when i pushed the trigger halfway down, there was still no reaction. I have discovered that the metering starts only when I push the M.L. button.

I completely don't know what to do, I have tried 2 other sets of new alkaline batteries and it does'nt want to release the shutter.

The body is in perfect condition, there are no scratches on it, even there is original foil on the bottom. I use a Helios-44M-4 with M42 adapter.

All in all, the camera:
-has no film inside,
-has got set of new alkaline LR44 Energizer batteries,
-starts metering only by pushing M.L. button,
-has the shutter ready to fire,
-doesn't want to release the shutter.

I will be glad if someone helps me work it out.



08-05-2011, 01:57 AM   #2
Pentaxian
aurele's Avatar

Join Date: Jan 2011
Location: Paris, France
Photos: Albums
Posts: 2,906
it's strange because it's suppose to start metering with pressing shutter half way.

Try to push the bouton that allow to rewind the film (under the body, on the shutter side.) it will bring the shutter count at 0.

Then try again to take a shoot.

(on my super A, i can't go further to 37 shoots, thebody refuse to shoot.)

It's quite odd because all you discribe is link generally to a battery probleme, but your batteries are new !
08-05-2011, 03:13 AM   #3
Junior Member




Join Date: Jul 2011
Posts: 30
Original Poster
Nothing. My shutter count is at [S].
The shutter is cocked and doesn't want to fire at all.

The manual says:
"If either battery is erroneously inserted, unexpected mishap may occur"

The camera may think that the shutter isn't cocked and that's why it doesn't want to fire...
The previous owner checked the camera on Maxwell LR44 batteries and assured me that everything was perfectly fine.

I dunno what's going on. And I wouldn't like to hear I've had my Pentax messed up.
08-05-2011, 08:28 AM   #4
Senior Member
older not wiser's Avatar

Join Date: Dec 2009
Location: East Yorkshire
Posts: 120
I haven't got a solution for you.
But I did duplicated everything you did on my p30 and it works just as it is supposed to. It will even fire the shutter with the lens off and the back open.
You may have a mechanical fault.

08-05-2011, 09:04 AM   #5
Junior Member




Join Date: Jul 2011
Posts: 30
Original Poster
QuoteOriginally posted by older not wiser Quote
But I did duplicated everything you did on my p30 and it works just as it is supposed to.
Did you even insert the batteries incorrectly?
08-05-2011, 10:14 AM   #6
Veteran Member




Join Date: Jan 2010
Location: Ferguson, Mo.
Photos: Gallery
Posts: 1,348
Hi Tom,dosent sound good.With polarity of battery reversed nothing is enabled,
should be a diode net in there to prevent any damage.
Might try to fire with self-timer,bypassing shutter button.
Good luck.
08-05-2011, 10:51 AM   #7
Junior Member




Join Date: Jul 2011
Posts: 30
Original Poster
Still doesn't work. I've found a P30 repair manual on the Internet, I think I'll try releasig the shutter mechanically.
08-05-2011, 11:25 AM   #8
Veteran Member




Join Date: Jan 2010
Location: Ferguson, Mo.
Photos: Gallery
Posts: 1,348
QuoteOriginally posted by GmcarsMAN Quote
releasig the shutter mechanically
Sounds like right direction for trouble shooting Tom.
Dont have P30, but do have P3n bought new long time ago and
a P5 bought used not quite a year ago.
P3n always been sweet to me.
P5 is a little "fuss budget",meter wont come up on half press.
Just press exposure lock(twice) and I get whats needed.
Lazy,so I leave it at that.Only bought it 'cause it came along with a M50/1.7
Again,good luck.

08-05-2011, 01:12 PM   #9
Junior Member




Join Date: Jul 2011
Posts: 30
Original Poster
I removed the bottom plate and released the shutter via the lever hidden below the lens mount.
Then, I reassembled the camera, inserted the batteries and... Still the same.

Metering starts with M.L. button, I cock the shutter and It doesn't want to release.
I dissasembled the camera once again, cocked and released the shutter a few times and no improvements. I left it cocked - I don't wish to unscrew the body again.

So, I still don't know where the problem is - the camera looks as if it just left the factory, so what could break inside? I think it is electronics' fault. Fortunately, the body cost me less than $20.

If somebody's got some more ideas what to do, it's very welcome.
08-05-2011, 05:35 PM   #10
Veteran Member




Join Date: Jan 2010
Location: Ferguson, Mo.
Photos: Gallery
Posts: 1,348
Can throw a huge array of theroms and suppositions Tom.

Would look real hard at that shutter button and associated contacts first.
Recall a member saying he had simular problem with P5 shutter button,to mine.
Stated that repeated pressing shutter button cleared problem.
Worked for him,I tried and wound up with sore finger and P.O'd,disbelieving attitude.

systematically...

Power up (battery install)...?..yes (have meter)

shutter button(DPDT elecro-mechanical switch)...?...indecissive,
need to test further.could be inhibited by debris that fouls contacts.
Perhaps with len's removed,try and clear with canned air or strong vacume
<caution> either may make matters worse,vacume could "smoke' electronics via static discharge.
Also,either could introduce debris into realitivily clean camera body.

Generally,Electronic component failure...

Discreet component drift of monolithic system...One part's value (eg. resistor) can vary over time
with age.Should that happen with one component,failure of "monolithic" system may result.
FWIW...most electronic components fail in 'open'or non-conductive condition.

Mechanical 'shock'...rapid acceleration(neg/pos) could cause breakage/failure with no apparent visable damage.

Thermo-shock..see mechanical shock.

Oxidation of electrical components...introduction of moisture.Not always apparent,will cause
'rust' that can inhibit or prevent electron flow.

Whole lot of other things,sure you get the gist of it.Broken wire,trace on circut board.Cold soldier joint
that finally manifest....on and on.


How much time you want to invest is limiting factor.
Will need proper tools to dis-assemble and service...spanners,small drivers,etc.
Theres a chap in Tennesee that works on them,Pentaxs is Co's name I believe.
08-06-2011, 04:59 AM   #11
Junior Member




Join Date: Jul 2011
Posts: 30
Original Poster
Oh, I'm from Europe, Tennesee is a bit far away from my home

My friend figured that my P30 may be a faulty one and that's why it's in such a good condition.
But I don't know.

-----------------------------------
Edit:

I just got back the money for my broken P30 and I gave up trying to bring it back to work. It will serve as an exibit

Yesterday I purchased a really nice silver Program A and I wait for the delivery. I told the seller about my history with the P30 and he said he's got a few of them and he'll give me one for free I hope these two will work perfectly - especially the Program A

Last edited by GmcarsMAN; 08-15-2011 at 02:30 AM. Reason: no need to solve the problem anymore
02-17-2012, 11:19 PM   #12
New Member




Join Date: Jan 2012
Posts: 2
My name is Tom and I am also new to the forum. My P30 has a faulty release magnet which the tech who looked at it seemed to think was unrepairable. It seemed to produce a similar symptom to your P30. Is this a common thing I wonder?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, button, film, p30, pentax help, pentax p30, release, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pearstone FreeWave Wireless Remote Shutter Release -> Pentax K-X? apac Pentax Camera and Field Accessories 2 05-17-2011 09:54 AM
Broken shutter-release button on Pentax K-x fashionista20100 Troubleshooting and Beginner Help 5 04-26-2011 06:25 PM
Pentax Me is missing its shutter release button iridescentstripes Pentax Film SLR Discussion 3 01-12-2010 05:37 PM
DIY Pentax Smooth Shutter Release petercrane Pentax Camera and Field Accessories 6 12-26-2009 04:42 PM
Is Pentax providing a cable shutter-release jack on the K-x? skid2964 Pentax DSLR Discussion 23 10-30-2009 12:04 PM



All times are GMT -7. The time now is 03:03 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top