Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-07-2011, 04:41 PM   #1
Inactive Account




Join Date: Aug 2011
Location: United States
Posts: 5
new k7 need help on playback feature

I have k10 and now new k7, and I have tried everything to get playback to show me photo instantly like my k10, I have read and read, looked into all options in menu and still am unable to get this to work. It has a very long delay when I even hit the playback button, so frustrating as I really like to look at photo right away to see what I have, this is very frustrating what am I doing wrong

08-07-2011, 05:24 PM   #2
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,531
I have a K-7 and I enclose my thoughts.

*In my setup, I switch off the LCD to save the battery.

*To review your shots, press the button 'View' on the top left of LCD

*If the last photograph is slow to come straight after your shot, this is because (a) you setup some in-camera processing or (b) your card is slow.

By default, the K-7 has some in-camera processing and you are better off to switch off (kill off) all in-camera processing. Examples of camera processing include (and are not limited to) lens distortion correction, High-ISO correction, ... More generally most Pentaxians would advise to perform any PP on the computer.

I hope that the advise will help. The K-7 is a great camera and you will enjoy it.
08-07-2011, 05:59 PM   #3
Inactive Account




Join Date: Aug 2011
Location: United States
Posts: 5
Original Poster
thank you!!!!!! this is very helpful and you are right I do have many settings I don't need ...I will give it a try and let you know, thanks again
08-10-2011, 09:48 PM   #4
Veteran Member
Immunogirl's Avatar

Join Date: Dec 2010
Posts: 313
Try a faster card - I had that problem till I got a class 10 card. It took forever for playback with my class 6 cards.

08-11-2011, 12:49 AM   #5
Veteran Member




Join Date: Nov 2010
Location: Fife, Scotland
Posts: 834
Think my card is class 6 and there isn't any replay delay.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k10, k7, pentax help, photo, playback
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
HD playback is grainy Zoomer_one Pentax K-r 7 08-13-2011 01:48 PM
Playback other Jpegs on a K10 stjohndunn Digital Processing, Software, and Printing 5 09-11-2010 12:15 PM
K-7 movie mode playback Stephanus Video and Pentax HDSLRs 3 04-10-2010 02:09 PM
Fn and playback buttons get locked? a101 Troubleshooting and Beginner Help 9 03-02-2010 10:24 AM
K-m tip: Playback quick-zoom-out feature dave9t5 Pentax DSLR Discussion 3 05-04-2009 09:33 AM



All times are GMT -7. The time now is 04:22 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top