Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-07-2011, 10:48 PM   #1
Senior Member




Join Date: Feb 2011
Location: connecticut
Photos: Gallery
Posts: 248
why am i getting a purple cast in some of my photos?

it seems that i am getting a purple cast to about half of my shots , which i was not getting , previously, noticed this with a k35mm lens and fa50 1.7 lens, most recently; this is not a purple fringing in strong light, ( as in purple outline of branches or leaves in strong sunlight) but just general purple cast to the whole frame, however some shots come out fine, but the next may have this cast to it, camera is k-5.
thanks

08-07-2011, 11:24 PM   #2
Pentaxian
twitch's Avatar

Join Date: Nov 2009
Posts: 4,571
In order to figure this out can you let us know the answers to these Q's:
Are you shooting in RAW or JPEG?
If RAW, what software are you using to process your photos?
Are you using auto white balance, or choosing one of the presets, or custom WB?
08-07-2011, 11:33 PM   #3
Veteran Member
Jodokast96's Avatar

Join Date: Oct 2007
Location: Erial, NJ USA
Photos: Gallery | Albums
Posts: 2,132
QuoteOriginally posted by twitch Quote
In order to figure this out can you let us know the answers to these Q's:
Are you shooting in RAW or JPEG?
If RAW, what software are you using to process your photos?
Are you using auto white balance, or choosing one of the presets, or custom WB?
More importantly than all of that, a sample image with EXIF intact would work wonders.
08-08-2011, 04:29 AM   #4
Senior Member




Join Date: Feb 2011
Location: connecticut
Photos: Gallery
Posts: 248
Original Poster
shooting in jpeg, auto white balance, not quite sure how to get a photo on here as this won't let me download one from my computer , it seems. i need an http something or other?

08-08-2011, 05:35 AM - 1 Like   #5
Veteran Member




Join Date: Jul 2010
Location: Lyngby, Copenhagen
Photos: Albums
Posts: 742
It's most likely due to auto white balance. I've seen the same when shooting eg. near yellow painted walls or lots of unpainted wooden furniture. That can register with the camera as low colour temperature, which it then tries to compensate for.

Regards,
--Anders.
08-08-2011, 06:32 AM   #6
Senior Member




Join Date: Feb 2011
Location: connecticut
Photos: Gallery
Posts: 248
Original Poster
grays are what ends up purple the most, as in gray weathered boards, or a gray roof, i know i SHOULD shoot raw, but like the ease of jpeg, odd though how one shot can be fine and the next of the same thing, same settings, end up purple.
08-08-2011, 07:03 AM   #7
Veteran Member
chalion's Avatar

Join Date: Jan 2009
Location: SE Pennsylvania
Photos: Albums
Posts: 628
Just to cover all bases: have you tried changing the SDHC card? I know that some cards can do weird things sometimes......
08-08-2011, 08:06 AM   #8
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
Click the Manage Attachments button at the bottom of the screen while posting to get to a screen where you can upload photos. Or create a free account on flickr, picasaweb, photobucket, or some such and upload the picutre there then link to it here.

08-08-2011, 10:47 AM   #9
Senior Member




Join Date: Feb 2011
Location: connecticut
Photos: Gallery
Posts: 248
Original Poster
will try changing sd cards, couldn't load a photo from shutterfly. also, don't see a manage attachments button anywhere .
08-08-2011, 11:19 PM   #10
Veteran Member




Join Date: Jul 2010
Location: Lyngby, Copenhagen
Photos: Albums
Posts: 742
QuoteOriginally posted by dh4412 Quote
grays are what ends up purple the most, as in gray weathered boards, or a gray roof, i know i SHOULD shoot raw, but like the ease of jpeg, odd though how one shot can be fine and the next of the same thing, same settings, end up purple.
You don't have to shoot raw to correct this problem. Just abandon auto white balance. That's what I did in your situation. That solution has its own set of problems of course, like forgetting to actually set a proper white balance when the light changes.

Regards,
--Anders.
08-09-2011, 04:58 AM   #11
Senior Member




Join Date: Feb 2011
Location: connecticut
Photos: Gallery
Posts: 248
Original Poster
does it make sense that this happens with certain lenses and not others?
08-09-2011, 06:14 AM   #12
Site Supporter
Site Supporter
SpecialK's Avatar

Join Date: Dec 2006
Location: So California
Photos: Gallery
Posts: 14,942
QuoteQuote:
don't see a manage attachments button anywhere .
Below the post text box is small a pink rectangle containing the black words Attach Photos or Files.

Below that is a white box with the words Manage Attachments. Click on that.
08-09-2011, 08:33 AM   #13
Senior Member




Join Date: Feb 2011
Location: connecticut
Photos: Gallery
Posts: 248
Original Poster
i guess the ' post quick reply' which i was using is not the right place to download photos from the computer, also, the file size with my k-5 is too big using the ' post reply ' thing over there on the left...... i'll figure this out eventually.
08-09-2011, 08:58 AM   #14
Veteran Member
Squier's Avatar

Join Date: Apr 2009
Location: Oxfordshire UK
Photos: Albums
Posts: 707
If the other suggestions dont help your purpleness, hunt down a free proggy called Puprle Fringe Killer ( PFK ).

Its a great plugin action for Adobe
08-09-2011, 11:43 AM   #15
Senior Member




Join Date: Feb 2011
Location: connecticut
Photos: Gallery
Posts: 248
Original Poster
purple shot with k35 f3.5, and the boards with fa50 f1.7, the boards are basically the correct coloration, only thing i did was to crop both these to fit file sizes for downloading
Attached Images
   
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, cast, lens, pentax help, photography, shots
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to control green cast in scans? ismaelg Film Processing, Scanning, and Darkroom 10 08-09-2011 04:34 AM
Help removing partial color cast? klh Digital Processing, Software, and Printing 9 07-26-2011 03:08 AM
K20d AND 'LIGHT CAST' philippe Pentax DSLR Discussion 15 11-28-2010 10:11 AM
Colour cast following monitor calibration danny38th Digital Processing, Software, and Printing 11 10-12-2010 08:57 AM
Preserving Color Cast With RAW zombieCat Digital Processing, Software, and Printing 18 07-05-2010 01:04 AM



All times are GMT -7. The time now is 11:45 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top