Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-11-2011, 10:35 PM   #1
New Member




Join Date: Jul 2011
Location: Brisbane
Posts: 5
K100D Super and Yongnuo YN560 Flash

I just bought a Yongnuo YN560 and I can't get it to fire while attached to the hotshoe on my K100D Super. It will fire wirelessly if set on the S1 & S2 slave settings when the in-camera flash fires.

I have tried with the camera set to M, TV, AV and Auto. The Flash Mode is set to "Manual Discharge". The camera User Manual only describes how to use genuine Pentax flashes. Does anyone know what settings I should have on the camera?

I assume that the mode on the flash itself should be set to M (manual).

I haven't previously used an external flash so I have probably missed something basic in the set-up.

Or more ominously, perhaps my hotshoe or the flash hotshoe mount are defective?

Any advice would be greatly appreciated. Thanks guys.

08-11-2011, 11:23 PM   #2
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,695
Reading some of the reviews of this flash, it seems to have a checkered record of operation with various Pentax cameras. I don't have one, but it does sound like it should work in manual mode without any fancy settings enabled/disabled. But do check your flash mode on both the flash and camera, then see if there is any flash discharge from the hotshoe you can get it to do, whether or not it registers in the exposure. One of the reviewers of the flash indicated a similar experience to yours - hopefully it can be worked out for you...
08-11-2011, 11:40 PM   #3
New Member




Join Date: Jul 2011
Location: Brisbane
Posts: 5
Original Poster
Problem solved! I put the camera's Custom Settings back to normal and it works just great. Honestly, for the price (US$65 - AUD$60) you just can't go wrong. P-TTL would be nice but they start about three times this price. Thanks for the advice though! Appreciated.
08-11-2011, 11:55 PM   #4
Veteran Member




Join Date: Apr 2011
Location: San Diego
Photos: Gallery
Posts: 883
set the flash to M mode, set your camera to M as well, make sure your shutter speed is 1/180 or slower. now try to fire it

08-12-2011, 12:22 AM   #5
Inactive Account




Join Date: Dec 2008
Location: North Carolina
Photos: Albums
Posts: 1,720
I have a K100D and a YN560, I didn't have to do anything special, just set the camera to M and 1/180. Make sure the flash is fully seated into the camera's hotshoe.

You can test the flash with a multimeter, set it to measure voltage, one probe on the center pin, one on the outside of the foot. If it shows around 3v, the flash should be fine.

I just tested mine, above 1/180 it definitely will not fire, I'm assuming the camera disables the hotshoe.

Last edited by elliott; 08-12-2011 at 12:46 AM.
08-12-2011, 12:56 AM   #6
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,695
There is no HSS mode for the camera to be able to support shutter speeds of faster than flash sync speed (1/180).
08-12-2011, 01:11 AM   #7
New Member




Join Date: Jul 2011
Location: Brisbane
Posts: 5
Original Poster
Thanks again guys. I think it was a case of what the IT people euphemistically call "End-User Problems". Cheers and happy snapping.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, fire, flash, hotshoe, k100d, mode, pentax help, photography, settings, yn560, yongnuo
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yongnuo YN560 compability mindglow Flashes, Lighting, and Studio 16 07-29-2012 12:35 PM
Using K5 and Yn560 flash off camera faulknern Pentax K-5 4 05-18-2011 11:34 AM
upcoming Yongnuo flash Pentaxor Flashes, Lighting, and Studio 6 03-30-2011 05:09 AM
Flash unit for K100D Super DafTekno Pentax DSLR Discussion 2 10-01-2010 08:15 PM
Cactus v4 vs YongNuo RF-602 for K100D and K-7 raider Pentax Camera and Field Accessories 12 01-12-2010 10:00 PM



All times are GMT -7. The time now is 01:01 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top