Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-03-2011, 08:50 PM   #16
Pentaxian
Sagitta's Avatar

Join Date: Feb 2011
Location: Maine
Photos: Gallery
Posts: 2,912
Original Poster
I fixed it! (sort of)

I've left it without batteries for a few days, in hopes of clearing anything wonky as far as firmware may go, and when I went to try it with fresh batteries, it still didn't work.

Thats when I figured "if this sucker is broken and out of warranty, breaking it more certainly won't matter". I then took a small flathead screwdriver and very carefully poked/prodded/urged along the plastic gear thats visible inside the lens mount next to the mirror and SNAP. The shutter fired. And fired again. And again. Then it stuck. I repeated what I did before, and this time it stuck open.

This means that I probably have a bit of dust/gunk/crap inside the camera around the gears that work the shutter, so I repeated the 'gently poke it with a sharp metal object' bit and the shutter snapped shut again.

That's when I violated every DO NOT DO THIS RULE known to man and whipped out Ye Can of Compressed Air and blasted that gear and the area immediately around it.

So far the camera is behaving itself again. At least I now know if it has something wrong its now a CLA and not a "return it because its busted" routine.

09-03-2011, 09:06 PM   #17
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,148
Good luck with the fix! If your mirror was down while you did the compressed air bit, you probably did not damage the shutters. We hope. Sincerely.
09-03-2011, 09:27 PM   #18
Pentaxian
Sagitta's Avatar

Join Date: Feb 2011
Location: Maine
Photos: Gallery
Posts: 2,912
Original Poster
QuoteOriginally posted by Canada_Rockies Quote
Good luck with the fix! If your mirror was down while you did the compressed air bit, you probably did not damage the shutters. We hope. Sincerely.
I wasn't aiming at the shutters, but rather the gears off to the side of the mirror. I wasn't about to aim the air anywhere close to the sensor - last thing I need is to break THAT. I've fired a bunch of shots off since, and so far the camera is behaving itself. If the issue starts rearing up again, I'll ship the camera off to get a professional cleaning.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, cause, half, home, hook, lens, lenses, pentax help, scroll, sd, shot
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Explaining DFS and HDR Rashedul Photographic Technique 1 09-21-2010 08:24 PM
Took a K-x out tonight Zig Troubleshooting and Beginner Help 19 05-20-2010 01:51 PM
Black & White Just for tonight TLiivo Photo Critique 3 05-15-2010 02:35 AM
Night Orion Tonight ajuett Post Your Photos! 3 02-19-2010 07:55 AM
Night Moon tonight Mike.P Post Your Photos! 9 12-05-2009 02:04 AM



All times are GMT -7. The time now is 06:45 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top