Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-29-2011, 07:58 AM   #1
New Member




Join Date: Jul 2010
Posts: 24
DA 70 f2.4 auto focus problem

I use a DA 70 f2.4 on K-7.

The auto focus was fine before, and I leave the camera for a week.

But today the auto focus cannot work anymore. I can hear the motor noise but the lens does not move at all.

Please help.

Any suggestions?

08-29-2011, 08:37 AM   #2
Veteran Member
snappychappy's Avatar

Join Date: Jun 2010
Location: Leeds
Posts: 1,636
Is the battery fully charged? Try removing the lens and re-fitting, check to see if the contacts on the lens look clean, ensure you haven't accidentally knocked the focus leaver to "manual", try other lenses to eliminate camera issue's.
08-29-2011, 08:40 AM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,949
Check the AF levers- sounds like they're not connecting properly.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-29-2011, 08:53 AM   #4
New Member




Join Date: Jul 2010
Posts: 24
Original Poster
Thank for your quick reply.

1. it is in AF mode.

2. I mount, remount the lens several times.

The problem still there.

08-29-2011, 09:11 AM   #5
Junior Member




Join Date: Jun 2011
Location: Singapore, Farrer Park
Posts: 44
Do you have any other camera bodies to test it on?
Have u swapped lenses and checked to verify if its a lens specific issue or body issue? :x

Just a suggestion for troubleshooting
08-29-2011, 09:53 AM   #6
New Member




Join Date: Jul 2010
Posts: 24
Original Poster
QuoteOriginally posted by kneonx Quote
Do you have any other camera bodies to test it on?
Have u swapped lenses and checked to verify if its a lens specific issue or body issue? :x

Just a suggestion for troubleshooting
That's the only body and auto focus lens I have...

I will try to ask my friends first.
08-30-2011, 06:48 AM   #7
New Member




Join Date: Jul 2010
Posts: 24
Original Poster
I clean the contacts again and again. Now, it works:-)
08-30-2011, 09:20 AM   #8
Junior Member




Join Date: Jun 2011
Location: Singapore, Farrer Park
Posts: 44
Good to hear haha i guess this would be a new "fix" to try if something happens to AF
clean the damn contacts~ haha maybe it'll solve a bunch of SDM issues too haha

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
auto, da, da 70 f2.4, f2.4, focus, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
SDM 16-50/2.8 auto focus problem nalilord Ask B&H Photo! 3 07-12-2010 12:42 PM
K10D auto focus problem dales Pentax DSLR Discussion 3 10-07-2009 09:09 PM
Auto Focus Problem - Help!! kev.pride Pentax DSLR Discussion 6 09-19-2008 05:03 PM
K10D auto focus problem? Tom C Pentax DSLR Discussion 18 05-08-2008 01:13 AM
DFA 100mm auto focus problem Mallee Boy Pentax SLR Lens Discussion 6 02-24-2008 09:50 PM



All times are GMT -7. The time now is 07:11 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top