Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-25-2011, 12:30 PM   #1
New Member




Join Date: Sep 2011
Posts: 3
Lens not registering with camera

Hi there,

I just bought a 50mm FA 1.4 lens for my Pentax Kr. It worked and took beautiful photos for about a month. Last night, I put the lens on and turned on the camera and there were no numbers registering on my LCD screen. It says F---.

I tried taking the battery out and back in. I tried removing the memory card and back in. I tried MF, AF. Nothing is helping register the numbers. I put my other lenses on and they work just fine, so I feel like it's just the 50mm FA 1.4 lens that isn't working.

Can anyone help me troubleshoot this, or is my lens bad? I took immaculate care of this thing so there is no reason for it to stop working on my account! Thank you!!!

Brooke

09-25-2011, 12:39 PM   #2
Veteran Member
jolepp's Avatar

Join Date: Oct 2010
Location: Finland
Photos: Albums
Posts: 3,196
A simple, easy to fix issue would be the aperture ring of the lens in a position other than 'A' (?).
09-25-2011, 01:15 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,941
Also, make sure you enable the "allow aperture ring setting other than A" option, as then you'll be able to shoot regardless of the aperture setting in M mode

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

09-25-2011, 01:41 PM   #4
Veteran Member
RioRico's Avatar

Join Date: Jun 2008
Location: Limbo, California
Posts: 11,264
Another possibility: Dirty contacts. I use a teflon eraser to keep the pins clean.

09-25-2011, 03:22 PM   #5
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
There is a small button on the aperture ring you have to push to turn the ring to the "A" position on the lens. Chances are you just slipped out of A. The flashing F-- is telling you the camera doesn't know what to do with the lens. Per the advice above, you can set the custom menu item that says "Use Aperture Ring" to Permitted but that won't change the operation of the lens when not on the A position.

09-26-2011, 04:25 PM   #6
Veteran Member
LegOverHead's Avatar

Join Date: Sep 2011
Location: California
Photos: Gallery | Albums
Posts: 369
QuoteOriginally posted by Adam Quote
Also, make sure you enable the "allow aperture ring setting other than A" option, as then you'll be able to shoot regardless of the aperture setting in M mode
that fixed my problem also! thanks adam.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50mm, camera, fa, lens, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Welcome! Post on PentaxForums without registering Adam Visitors' Center 27 03-03-2017 12:45 PM
Registering Extended Warranty ToGo Pentax DSLR Discussion 5 03-31-2011 01:48 PM
A Sentence or Two for New Members Registering? Ira Site Suggestions and Help 17 11-17-2010 10:05 AM
Problem Registering At DPReview amir5831 General Talk 22 07-09-2007 04:18 PM



All times are GMT -7. The time now is 05:45 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top