Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-16-2011, 03:54 AM   #1
Junior Member




Join Date: Oct 2011
Location: On Ilkley Moor Baht 'at. Yorkshire, UK
Posts: 31
GX20 flash recognition

Well I have an intermiitend problem with my GX20 and external flash. I have the Samsung 360 flash but there are times that when I attach it to the GX20 that they dont seem to know that each other are there, ie the flash doesnt switch to P-TTL and the shutter doesnt set to the flash sync and when I shoot, there is no flash firing. It can happen in any shooting mode, I usually shoot in apperture priority and have the iso set to my rear thumb wheel but even switching to P mode doesn't seem to help.

As you would expect, this usually happens when I am under pressure to get a group shot at a community meeting or convention and people are starting to think that I cant use my gear....

Any ideas or advice....and all kit is about 3 years old with minimal use

10-18-2011, 10:15 PM - 1 Like   #2
Loyal Site Supporter
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,554
QuoteOriginally posted by Aardvark Quote
Well I have an intermiitend problem with my GX20 and external flash. I have the Samsung 360 flash but there are times that when I attach it to the GX20 that they dont seem to know that each other are there, ie the flash doesnt switch to P-TTL and the shutter doesnt set to the flash sync and when I shoot, there is no flash firing. It can happen in any shooting mode, I usually shoot in apperture priority and have the iso set to my rear thumb wheel but even switching to P mode doesn't seem to help.

As you would expect, this usually happens when I am under pressure to get a group shot at a community meeting or convention and people are starting to think that I cant use my gear....

Any ideas or advice....and all kit is about 3 years old with minimal use
I suggest resyncing the connection before heading out so that the communication channel is set properly. It might be as simple as one or the other getting set to the wrong channel somehow. You have 25% chance of getting it right if you don't do the sync routine. It only takes a few seconds.
  1. Camera off
  2. Flash off
  3. Mount flash
  4. Turn on Camera
  5. Turn on Flash
10-19-2011, 04:34 AM - 1 Like   #3
Senior Member




Join Date: Mar 2009
Photos: Gallery
Posts: 226
Does the flash fires separately? Does it works on the camera in any mode at all?

Actually I've had the problem with external flash on my k20. It did not fire at all. The problem was in the shortened hot-shoe contacts.

Otherwise if the flash works time-to-time it can be bad contact. Check the pins on the flash mount or clear the contacts on the hot-shoe.
10-19-2011, 07:43 AM   #4
Junior Member




Join Date: Oct 2011
Location: On Ilkley Moor Baht 'at. Yorkshire, UK
Posts: 31
Original Poster
Thanks both, no when it refuses to fire it refuses to fire. I can get it to test fire onlyby pushing the lit button on the flash.

I think that what I need to do is to follow the synchronisation advice.....I have never done this as I usually have the camera on and then I fire up the flash as I pull it out of my bag before sliding onto the camera.

My guess is that Canada Rockies has hit the nail on the head.....I came to the GX20 from a manual 35mm background and have never had program flash before.

Having tried a couple of times in the last hour, following this routine, it always works first time.........lets see if it works when I am under pressure again

10-19-2011, 08:15 AM - 1 Like   #5
Loyal Site Supporter
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,554
QuoteOriginally posted by Aardvark Quote
Thanks both, no when it refuses to fire it refuses to fire. I can get it to test fire onlyby pushing the lit button on the flash.

I think that what I need to do is to follow the synchronisation advice.....I have never done this as I usually have the camera on and then I fire up the flash as I pull it out of my bag before sliding onto the camera.

My guess is that Canada Rockies has hit the nail on the head.....I came to the GX20 from a manual 35mm background and have never had program flash before.

Having tried a couple of times in the last hour, following this routine, it always works first time.........lets see if it works when I am under pressure again
It's always the simple things that raise my blood pressure as well. I have synched my AF 540 FGZ flash only once on the K10, and it has worked the few times I have tried it since. Flash for me is a last resort sort of thing, although I am considering using it for bird photography thanks to some very nice photos taken by others on this forum. It would get rid of the problems I have with lighting at our bird feeder.
10-19-2011, 09:46 AM - 1 Like   #6
Inactive Account




Join Date: Mar 2011
Photos: Gallery | Albums
Posts: 302
I had this same behavior with an older non P-TTL flash (AF220T) -- always fires the first time, but very sparsely after that. If I put it in X-sync mode on my K20D, it fires correctly every time. Since I paid $20 for the flash, I'm happy that it works in any mode at all.

Hope that helps.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
flash, gx20, mode, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Advice needed for: off camera flash guns for Samsung GX20 samsungx20 Pentax DSLR Discussion 8 07-11-2011 01:02 PM
Aperture recognition on k10 cbaumgaertner Pentax DSLR Discussion 6 06-18-2010 09:52 AM
Pentax recognition (official) Marc Langille Travel, Events, and Groups 14 09-21-2009 06:02 PM
Face recognition on instant preview for Pentax. vitalsax Pentax DSLR Discussion 13 01-14-2009 07:15 PM
Pentax on HSN and QVC, good for brand recognition? morfic Pentax DSLR Discussion 8 10-20-2008 06:04 PM



All times are GMT -7. The time now is 02:50 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top