Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-24-2011, 10:22 PM   #1
Inactive Account




Join Date: Oct 2011
Location: Bundanoon, NSW, and Hong Kong SAR
Posts: 3
K20 D Locks up

I know there is an old thread on this subject, but none of the solutions suggested there have worked. So perhaps there are some fresh ideas.
I have a K20D which is my first Pentax after a succession of Nikons and medium format cameras (Bronica, then Hasselblad).
I have found it generally reliable, but from time to time it just locks up for no apparent reason.
Most times, it has come good again after random changing of different settings, but not this time.
Three days ago it was working fine, then next time I went to use it, I switched on, got the detailed information display (p.2) and the top window with full battery indicator F- - and remaining shots (544) and nothing else.
The viewfinder shows no information and the shutter will not work.
I have tried different SD cards (all good quality) and battery combinations (I have a second battery holder), but nothing seems to work.
Can anybody help?

10-25-2011, 03:40 AM   #2
Veteran Member




Join Date: Jul 2009
Location: London
Posts: 866
Not sure if it's anything to do with your problem, and maybe I've misunderstood what you've written, but F-- is to do with aperture ring use, not the battery.

See 36 in the custom menu. If not set to Permitted, the shutter will not release with certain lenses. In my manual this is on page 251.

At page 250 is a caution," When aperture ring is set at other than A (Auto) position or a lens without an A position or accessories such as an auto extension tube or auto bellows are used, camera does not operate...'.

Any of this match your circumstances?
10-25-2011, 04:00 AM   #3
Loyal Site Supporter




Join Date: Mar 2009
Location: Southern Indiana
Photos: Gallery
Posts: 15,120
I think you just have to send it in to get it fixed. My brand-new K20 did this periodically and Pentax replaced a circuit board in it and it was fine after that. Although, if it doesn't bother you too much, I guess you could just live with it.
10-25-2011, 04:14 AM   #4
Pentaxian
JohnBee's Avatar

Join Date: Sep 2008
Location: front of computer
Posts: 4,497
I had this exact same problem with TWO K20D's

And after weeks of testing I managed to narrow my lock-ups down to a faulty card mounting process. Which was none other than improperly setup SD card drivers. After I re-installed windows, everything went away and the K20's were all fine.

And I identified this by taking out the camera battery(resetting) and then formatting the card with the camera(not PC). After which I put the camera through its paces and found everything was A-OK. And so I followed-up with taking the card out of the camera and placing it into my PC card reader. At which point, I'd access it using ACR(which writes crumbs to the card btw) only to find out that the camera would then freeze after I'd try to use it again. - And I found that the freeze would occur when the camera would have to write to the card.

Hope this helps.

PS. I spent many weeks trying to pinpoint the source of this error with my K20's and I couldn't believe how obvious it was when we discovered the cause. And to make matters worst, both my workstation and notebook were corrupting my SD cards. And so I concluded that this was likely a Windows(service etc) setting that would get turned-off at some point along the way.


Last edited by JohnBee; 10-25-2011 at 10:18 AM.
10-25-2011, 08:38 AM - 1 Like   #5
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
I would be inclined to look at the lens as well. If you are using an A, FA, DA, etc type lens, switch your camera to manual focus just to see if you can fire the shutter. If you are using an A or FA type lens, make sure the aperture ring is in the "A" position. If you are using an M, K, M42, and you have set your custom menu setting 'use aperture ring' = permitted, switch your camera to Manual focus and see if you can fire the shutter. Even with an MF lens, with the camera in AF-S, the camera will not take a photo unless it detects focus lock (but you knew that already, correct?).

10-25-2011, 08:12 PM   #6
Inactive Account




Join Date: Oct 2011
Location: Bundanoon, NSW, and Hong Kong SAR
Posts: 3
Original Poster
Although I am not using a special lens, extension tube, etc. I set the aperture ring to "A". Problem solved!
Many thanks to all who offered advice.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, information, locks, pentax help, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K1000 mirror locks up with film advance awsutter Pentax Film SLR Discussion 4 12-27-2010 12:34 PM
Machinery K20 on K20 love (car related) ga-hing Post Your Photos! 8 09-03-2010 04:58 PM
K200 locks up bpeek73 Pentax DSLR Discussion 2 11-30-2009 03:02 PM
Tripods - reliability of flip locks vs twist lock VAV Pentax Camera and Field Accessories 21 07-10-2009 09:28 AM
Combined Locks Newbie ombre Welcomes and Introductions 2 10-30-2007 11:07 AM



All times are GMT -7. The time now is 05:45 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top