Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-25-2011, 11:25 AM   #1
New Member
prime's Avatar

Join Date: Feb 2010
Location: Gothenburg
Photos: Gallery | Albums
Posts: 15
K20D cant run the scm motor

I bought a DA star 50-130. and ofcause the focus motor gave up. After 10 days I got it back, but now it seems to bee that the camera dosen`t run it. I tryed it on a different house, and the lens work fine there. (it diddent work on other houses when it gave up on mine K20). Has anyone have any experient that the ultrasonic motor can destroy the conection inside the house? I have tryed other lenses on my house with smc motor and none of them work.

10-25-2011, 03:59 PM   #2
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
Does the Screw drive AF work with the 50-135? You may have a very special camera there. There are some people with dead SDMs that would like to have a k20d with a dead SDM drive. I've heard of this once before here on the forums. The thread title said something like 'I broke my K20d and couldn't be happier'. Might be worth a search.

10-25-2011, 04:07 PM   #3
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,783
I guess it is conceivable that damage could happen to the circuitry in the body if the lens due to a fault shorts the two power contacts in the lens mount.

But that's just a guess. I have had an sdm lens die on me without any adverse effect on the camera.

If you have, or can borrow, an old power zoom lens you could see if that would work. It uses the same two power contacts.
10-26-2011, 01:11 AM   #4
New Member
prime's Avatar

Join Date: Feb 2010
Location: Gothenburg
Photos: Gallery | Albums
Posts: 15
Original Poster
The screw drive AF work, but the focus is very bad.

10-26-2011, 01:19 AM   #5
New Member
prime's Avatar

Join Date: Feb 2010
Location: Gothenburg
Photos: Gallery | Albums
Posts: 15
Original Poster
@Ole. I have tried other lenses with ultrasomoc motor, and none of them work with my camera. My lens witch have got a new motor is working perfekt on other houses. These ara new ons and I dont know anybody with and old one. As you menshend the question is if it is possible that the lens could have dammege the circuity in the body. I have talked with a pentax service and they say that this is not possible, but I have no other explanation. I dont want to pay for a repair, if it turns out that other have had the same problems.
10-26-2011, 06:48 PM   #6
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,783
I don't have a K20D so I cannot check how it is constructed, but could it be the case that the power contacts in the body could be bent so that they do not make contact with the lens contacts anymore?
10-26-2011, 08:10 PM   #7
Senior Member




Join Date: Nov 2009
Location: Orlando
Photos: Albums
Posts: 104
It happen to me last July (Independence day) trying to switch fast from tele to wide (shooting fireworks) and forgot to turn off the camera, after that my HSM lens stop working, maybe I accidentally shorted the 2 contacs. I ended up selling the camera because the repair will cost $200 to $300 according to Camera Repair Japan.
12-23-2011, 01:00 PM   #8
New Member
prime's Avatar

Join Date: Feb 2010
Location: Gothenburg
Photos: Gallery | Albums
Posts: 15
Original Poster
Well. I got the repair of the house for free. The shortcut of the ultrasonic motor in the warranty period cowered the cost of repairing the house.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
house, motor, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K20D Focus motor minitw Troubleshooting and Beginner Help 3 01-21-2011 08:22 AM
For Sale - Sold: SCM Pentax DA* 16-50mm f/2.8 SDM (US) cztexas Sold Items 7 09-27-2010 10:20 AM
For Sale - Sold: SCM Pentax 16-50mm f/2.8 DA* SDM (US) Green Chile Sold Items 3 09-20-2010 10:43 AM
People On a training run cupic Post Your Photos! 4 03-03-2010 01:17 AM
Sports On the Run 8540tomg Post Your Photos! 8 11-15-2009 05:17 PM



All times are GMT -7. The time now is 07:19 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top