Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-04-2011, 02:42 PM   #1
New Member




Join Date: Nov 2011
Posts: 2
Pentax K-x + SMC 75-150 f4 problem

Hi, I have my K-x for almost a year now and I've been using it with the default 18-55 lens without any problem.

I recently bought, on ebay, a Pentax SMC 75-150 f4 lens, from a seller with 100% feedback and only good reviews (over 2000 sells, mostly photo related).

I recieved it today, it appears to be in good condition but when I mounted it on my K-x I cant take any photo with it.

Where the f value should be I just get F - - - flashing and I can't change the shuter speed.

I have tryed reseting the camera settings fo default but it didn't make a difference. The camera is running on it's original 1.00 firmware, is this a problem?

I atached a picture showing the config menu whit the lens mounted:




Hope you can help me with this.

Best regards
Rafael

11-04-2011, 03:26 PM   #2
Veteran Member
jolepp's Avatar

Join Date: Oct 2010
Location: Finland
Photos: Albums
Posts: 3,196
Most likely you need to allow the use of the aperture ring (and then using stop down / green button metering), see: https://www.pentaxforums.com/forums/pentax-beginners-corner-q/110658-using-ma...x-dslrs-f.html.
11-04-2011, 04:09 PM   #3
Veteran Member
causey's Avatar

Join Date: Feb 2009
Location: Arlington, VA
Photos: Albums
Posts: 3,758
The lens is an M lens--> you need to set the camera to the M mode, then press the green button to take an exposure.

Last edited by causey; 11-04-2011 at 04:28 PM.
11-04-2011, 06:52 PM   #4
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,456
QuoteOriginally posted by causey Quote
The lens is an M lens--> you need to set the camera to the M mode, then press the green button to take an exposure.
This will work only if you have set the camera to Permit Aperture Ring. It is in the camera's menus.

11-04-2011, 06:55 PM   #5
New Member




Join Date: Nov 2011
Posts: 2
Original Poster
Thanks a lot for both your replys. I have solved my problem.

It was probably a noobish thing but the camera is not actualy mine, it's my girlfriend's but i'm the one who is called up to solve all the "technological problems", specially when it involves English (we are form Portugal).

I will definetly be attending this forum more often and try to learn a bit more even though I don't own the camera.

Once again, thanks a lot.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, default, f4, k-x, lens, pentax, pentax help, pentax k-x smc, photo, smc
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
SMC-Pentax-FA-645-150-300mm-F5.6 for landscape work spacevoid8 Pentax Medium Format 5 05-31-2011 04:02 AM
For Sale - Sold: SMC Pentax-M Lenses (100, 120, 135, 150, 200) - Some Rare All Near Mint (US) myfotoguy Sold Items 12 04-28-2011 08:37 PM
HELP!!!! Sigma 150-500mm Problem fccwpe Pentax SLR Lens Discussion 3 03-01-2010 08:30 PM
For Sale - Sold: Pentax-M SMC 135mm f/3.5, will trade evenly for SMC-M 75-150/4 wallyb Sold Items 3 06-22-2009 06:23 PM



All times are GMT -7. The time now is 05:07 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top