Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-22-2011, 06:39 AM   #1
Veteran Member
jeztastic's Avatar

Join Date: Nov 2010
Location: Canterbury
Photos: Gallery | Albums
Posts: 596
K10D and flash syncing

Hi,

I'm sure this has been covered elsewhere, but I can't find anything relevant.

I want to use my onboard flash (K10D) to trigger an external ancient flash unit to which I have attached a optical trigger. It's not working at the moment, because the pre-flash triggers it too early. Can I turn off the pre-flash in any way?

Ta!

Jez

11-22-2011, 03:24 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,032
I think the pre flash will always fire with automatic lenses. Try manual mode, and if that doesn't work, then I think you'll need an actual manual lens.
11-22-2011, 03:43 PM   #3
Pentaxian




Join Date: Feb 2009
Location: Alameda, CA
Posts: 3,198
If the lens is auto (either has no aperture ring, or the aperture ring is at A), the built-in flash will be in p-TTL mode with pre-flash strobe. The pre-flash strobe triggers the optical slave as you observed.

You can:

- Get an optical slave trigger that can ignore the pre-flash strobe (Sunpak makes 2 of them, I think).
- Use a manual lens. In this case, the built-in flash will fire one strobe at full power.
- Get a small external flash (non p-TTL and preferably with multiple power settings) to attach to the camera body and use it to trigger the slave.
- Get a set of RF remote flash trigger.
11-22-2011, 04:18 PM   #4
Veteran Member
jeztastic's Avatar

Join Date: Nov 2010
Location: Canterbury
Photos: Gallery | Albums
Posts: 596
Original Poster
Thanks for the information. Got lots of manual lenses - will try that.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
flash, k10d, pentax help, pre-flash
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Syncing off camera flash with sync cord velingara Flashes, Lighting, and Studio 3 03-23-2010 07:47 AM
K10D+540 flash problem using trailing flash wirelessly PaulT Flashes, Lighting, and Studio 4 01-18-2010 10:00 AM
K10D+540 flash using trailing flash wirelessly PaulT Troubleshooting and Beginner Help 2 01-15-2010 03:01 AM
Lightroom syncing libraries? Javaslinger Digital Processing, Software, and Printing 1 12-11-2009 10:06 AM
Syncing Vivitar 283 to K100D w/out hot shoe jro Pentax Camera and Field Accessories 3 08-01-2008 03:43 AM



All times are GMT -7. The time now is 08:37 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top