Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-17-2011, 05:20 PM   #1
Junior Member




Join Date: Dec 2011
Posts: 28
stuck in Av mode

my camera LCD says it is in Av mode, whether in Green, P, Sv, Tv. Av, or Tav modes on the mode button. M, B, and X modes on the button shows up correctly in the LCD. I am using the Pentax 28-105 Power Zoom lens. thanks for any help.

12-17-2011, 05:29 PM   #2
Veteran Member
RioRico's Avatar

Join Date: Jun 2008
Location: Limbo, California
Posts: 11,264
Which camera? I'm not familiar with that lens -- does it have an M/A switch? Being "stuck in Av mode" usually happens when a non-A-type manual lens is mounted. Does this happen with any other AF or A-type lenses?
12-17-2011, 05:39 PM   #3
Site Supporter
HockeyDad's Avatar

Join Date: Mar 2011
Location: Michigan
Posts: 474
Similiar thread can be found here...

It could be that the Camera "thinks" you have a manual lens on. Maybe cleaning the contacts will help.
12-17-2011, 05:49 PM   #4
Veteran Member
RioRico's Avatar

Join Date: Jun 2008
Location: Limbo, California
Posts: 11,264
QuoteOriginally posted by HockeyDad Quote
It could be that the Camera "thinks" you have a manual lens on. Maybe cleaning the contacts will help.
I was going to suggest that, but then there would be a flashing F-- on the LCD screen too. OP has this same question in another thread -- is using a K20D. If the problem manifests with other lenses, it could be a camera problem. If it's only this lens, then it may be time for another lens. Or a good cleaning.

12-17-2011, 06:06 PM   #5
Veteran Member
Davidw0815's Avatar

Join Date: Jul 2011
Photos: Gallery
Posts: 434
Did you set the aperture ring to "A"?
12-17-2011, 08:56 PM   #6
Junior Member




Join Date: Dec 2011
Posts: 28
Original Poster
the camera is K20D. then lens is a Pentax FA lens, no m/af switch. I will try everybodies suggestions. thanks for the help...OOOOPS, just realized I had taken it off "A" button, now its not "stuck on Av"
12-17-2011, 09:07 PM   #7
Junior Member




Join Date: Dec 2011
Posts: 28
Original Poster
thx, you were right, I had taken it off "A" locked
06-12-2013, 02:52 AM   #8
Senior Member
mythguy9's Avatar

Join Date: Jun 2012
Photos: Albums
Posts: 274
QuoteOriginally posted by RioRico Quote
Which camera? I'm not familiar with that lens -- does it have an M/A switch? Being "stuck in Av mode" usually happens when a non-A-type manual lens is mounted. Does this happen with any other AF or A-type lenses?
Hi RioRico, can you please kindly confirm this? I mounted a M lens and the same thing happened, i.e. stuck in Av mode for P, Sv, Tv, and TAv. It's kinda worrisome so I just wanna confirm that this always happens to M lenses (I don't have auto lens to test... )

06-14-2013, 09:34 AM   #9
Veteran Member
Ben_Edict's Avatar

Join Date: Jul 2007
Location: SouthWest "Regio"
Photos: Albums
Posts: 3,303
QuoteOriginally posted by mythguy9 Quote
Hi RioRico, can you please kindly confirm this? I mounted a M lens and the same thing happened, i.e. stuck in Av mode for P, Sv, Tv, and TAv. It's kinda worrisome so I just wanna confirm that this always happens to M lenses (I don't have auto lens to test... )
Yes, manual lenses can only be used in Av (but the aperture will always stay open, during picture taking) or M. In M the aperture is stepped down correctly during expsoure and you can have a kind of semi-Automatic, when you push the Green Button, which takes an expsoure reading and sets the correct time for the aperture you have chosen.

Ben
06-14-2013, 11:00 AM   #10
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,958
QuoteOriginally posted by mythguy9 Quote
Hi RioRico, can you please kindly confirm this? I mounted a M lens and the same thing happened, i.e. stuck in Av mode for P, Sv, Tv, and TAv. It's kinda worrisome so I just wanna confirm that this always happens to M lenses (I don't have auto lens to test... )
This article might be of help:
https://www.pentaxforums.com/forums/pentax-lens-articles/110657-how-use-meter...k-x-k-7-a.html

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
av, button, lcd, mode, modes, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K 10 stuck on debug mode graveyardeyes Troubleshooting and Beginner Help 4 08-15-2011 12:09 PM
Pentax K100D stuck in manual mode LloydTifflin65 Pentax DSLR Discussion 2 04-20-2011 10:04 PM
Help! Mode Dial stuck? chriiisty Troubleshooting and Beginner Help 6 03-14-2011 01:05 AM
K20D get stuck on playback mode goldenzebra Pentax DSLR Discussion 5 10-11-2010 02:48 AM
K10D Stuck in AV mode mpodesta Pentax DSLR Discussion 10 04-27-2010 10:49 AM



All times are GMT -7. The time now is 02:46 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top