Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-30-2011, 10:35 PM   #1
Veteran Member




Join Date: Mar 2011
Location: Eastern Kentucky
Posts: 416
KX M type lens problem

Have had this problem before but it goes away after fooling with the lens and settings.Used the same lens all day but when I tried to use tonight the camera became unusable.Put a Pentax A50 mm f2 on the camera and it worked fine and normal.What is happening with the M type lens is that every moment made starts the mirror flopping and the shutter won't work.When I turn the dial it flops at every setting.Holding the shutter button half way the mirror flops continually.Between using the camera today I charged the batteries,reset white balance and iso.
Thanks,
Jake

12-31-2011, 03:16 AM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,636
You're talking about the digital K-x, right?

Are you shooting in M mode?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

12-31-2011, 06:14 AM   #3
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,361
He may have also reset the use aperture ring function. When he says he reset wb etc did he reset all functions?
12-31-2011, 06:16 AM   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,636
Here's the complete guide to shooting with manual lenses, should have you covered as long as there's nothing wrong with the camera:

https://www.pentaxforums.com/forums/pentax-lens-articles/110657-how-use-meter...k-x-k-7-a.html


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

12-31-2011, 08:17 AM   #5
Veteran Member




Join Date: Mar 2011
Location: Eastern Kentucky
Posts: 416
Original Poster
This is a Pentax K-X dslr.With M type lens with camera set to either auto pict,TV,AV or M It acts the same way,mirror flops continuous when shutter button is pressed.
Jake
12-31-2011, 08:22 AM   #6
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,636
Have you enabled the "allow aperture ring other than A" setting in the menu?

Manual lenses should only be usable in M mode on the K-x. I would also set your drive mode to single shot in case that's the problem.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

12-31-2011, 09:15 AM   #7
Veteran Member




Join Date: Mar 2011
Location: Eastern Kentucky
Posts: 416
Original Poster
Allow aperture ring other than A is set,just checked.Agree that M lens should be used with M lens and also the way I prefer to use the M lens but the camera gives me more problems with the lens flopping in M mode than TV or AV.The only reason I go to other modes is when the camera messes up in M.Seems to work correctly more often in Tv than M.Once when I was having this problem I used electronic cleaner to clean the contacts on the camera and base of the lens cured it for about a month,will find my cleaner and see if it will work now.Have went threw all the menu settings and unless I missed something everything looks to be correct but could have missed something.
Jake
01-01-2012, 07:58 AM   #8
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
You are aware the aperture ring setting is ignored in all other modes?

01-01-2012, 08:35 AM   #9
Veteran Member




Join Date: Mar 2011
Location: Eastern Kentucky
Posts: 416
Original Poster
Wasn't aware that the allow aperture ring setting was ignored.Got the KX so I could use my old lens so I set it to allow aperture
ring when the camera was new and have seen no reason to change it.
I have figured out what the problem is partly but it seems unlikely.The camera messes up on only one lens,a K mount CPC 28mm
f2.8 macro.Have put several M type lens on the camera and it works as it should but when the CPC is installed it just messes up.
Checking the lens mount on the CPC I find nothing is visually different than other K mount lens other than the appendage that moves the aperture is bent 3-5 degrees toward the inside of the lens.
Thanks,
Jake
01-01-2012, 09:22 AM   #10
Moo
Senior Member




Join Date: Jun 2008
Posts: 174
Sounds like what is described in this thread. Somewhere in there, there was talk of the issue only occurring when using certain lenses, for some people.
01-01-2012, 12:22 PM   #11
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,636
Yup, sounds like it might be the lens. Lever might be jammed or something.
01-01-2012, 01:07 PM   #12
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
Your previous thread about the subject: https://www.pentaxforums.com/forums/pentax-beginners-corner-q/168613-kx-28mm-...s-problem.html

https://www.pentaxforums.com/forums/pentax-dslr-discussion/167755-lens-flop-kx.html I'm quite sure the solution is there (insulate the contacts, see post #13)

---
Happy 2012
01-01-2012, 05:47 PM   #13
Veteran Member




Join Date: Mar 2011
Location: Eastern Kentucky
Posts: 416
Original Poster
sterretje

Sterretje-Am forgetful and forgot about the other thread,went back and read it and the one linked to it.

Adam-Do you think the bent lever on the lens might be causing the problem?

Thanks,
Jake
01-01-2012, 10:26 PM   #14
Veteran Member




Join Date: Mar 2011
Location: Eastern Kentucky
Posts: 416
Original Poster
Fixed the problem

After reading all the post I could find on the mirror flapping problem someone suggested looking in the camera body to see how the camera linked up with the leaver on the lens,I need to find that post and think him along with others.I bent the lever back to as near 90 degrees with the lens base as I could,now the lens works fine.
Thanks all,
Jake
01-02-2012, 01:50 AM   #15
Veteran Member




Join Date: Jul 2008
Location: Var, South of France
Photos: Albums
Posts: 1,071
Arrrrrgh, stop bending these levers!!!

A more subtle mod is to drill another locking hole into the lens, so it will lock halfway turned into the mount, before the aperture lever is engaged by the camera actuator...

This way, you can still use it as a true M lens if needed, by using the original locking hole.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, lens, mirror, pentax help, shutter, type, type lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can you help ID this lens type? subidoc Pentax SLR Lens Discussion 3 08-28-2011 06:02 PM
Is this a front focusing camera problem or lens problem? Lens tests Metalwizards Pentax K-r 15 03-06-2011 01:24 AM
what type of lens do i need?? HAKAWAY Troubleshooting and Beginner Help 8 12-16-2010 11:49 PM
What type of lens is this? yusuf Pentax SLR Lens Discussion 4 10-31-2010 07:04 AM
Is there any type of third party lens hierarchy? jeryst Pentax SLR Lens Discussion 8 01-02-2010 08:00 PM



All times are GMT -7. The time now is 10:50 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top