Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-03-2012, 07:29 PM   #1
New Member
Gander's Avatar

Join Date: Oct 2011
Location: Bremerton, WA
Posts: 17
K-5 lens, Sigma DL 70-300, settings

I have a new Pentax K-5 and I just bought a used Sigma 70-300 1:4-5.6 DL Super macro lens for it. The camera is set up for auto metering and AF,S mode.

I put it on the camera and then turn it on, but I can only use it in AV mode. I have tried other modes as well, but the screen still shows that it is AV mode. I tried TV and SV mode and still shows AV on the LED Screen. I tried pushing the green button but that didn't do anything. I takes great pictures in AV mode, so I guess I can live with that. In my settings menu, on the fourth section (c) I have the option #27 set to "permitted" because I have a couple of Manual lenses. But I even tried with it set to "Prohibitive" and that didn't solve anything, so I just left it on permitted.

Is this a problem with this lens or is this all it will work in? I hope I didn't buy a lemon.

I wasn't able to try it out before I bought. I purchased it on line from an auction house.


Last edited by Gander; 01-03-2012 at 07:32 PM. Reason: Expanded title to provide more information
01-03-2012, 07:36 PM   #2
Pentaxian
JinDesu's Avatar

Join Date: Jun 2011
Location: New York City
Photos: Gallery
Posts: 5,626
Could try wiping the contacts on the Sigma, but that's still a weird occurrence. Does M mode work? I'm assuming it does.
01-03-2012, 07:50 PM   #3
New Member
Gander's Avatar

Join Date: Oct 2011
Location: Bremerton, WA
Posts: 17
Original Poster
Yes, switching it to M mode, works fine.

I just picked up my camera and discovered that it has an Aperture ring.... who would of thought And guess what I just found... Auto mode, huh, I locked it in to "A" on the aperture and now everything works like it suppose to. The TV, SV, AV, TAV it all works. Wow that was a relief!!! The ring is small, I didn't even see it when I was looking over the lens. Now I feel like a complete NOOB.
01-03-2012, 07:52 PM   #4
Pentaxian
JinDesu's Avatar

Join Date: Jun 2011
Location: New York City
Photos: Gallery
Posts: 5,626
Aha, that would do it. Sorry I wasn't much help.

Reply
« Exif | Flash gear »

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
av, camera, dl, k-5, lens, mode, pentax help, screen, settings, sigma
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nikon D7000 + 70-300 VR vs. Pentax K5 + Sigma 100-300 highyellow1 Non-Pentax Cameras: Canon, Nikon, etc. 41 05-06-2011 07:40 AM
For Sale - Sold: Sigma 100-300 f4. Sigma 1.4 Teleconvertor. Sigma UV filter. Cases, Caps, Box & garethwebber Sold Items 3 12-03-2010 03:05 AM
Best settings for K10D and Sigma 28-300 bolek Pentax SLR Lens Discussion 0 05-25-2008 08:22 AM



All times are GMT -7. The time now is 05:16 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top